Open source IntelliJ Platform: Tests, Build, TeamCity...

Hi,

I recently checked out the source for the community edition and platform as outlined on the jetbrains.org site (http://www.jetbrains.org/display/IJOS/Download) and detailed on Check Out & Build Community Edition (http://www.jetbrains.org/pages/viewpage.action?pageId=983225).

I successfully built the project via the IDE. Then, as a first step beyond those detailed in the Check Out & Build Community Edition, I ran some tests. I didn't see any "Run" Configuations for the tests in the project or test targets the build file (idea\build.xml - note that "idea" is my project root folder), so I just ran those in a module - specifically "All in java-tests" (eg, idea\java\java-tests\testSrc). However, 4751 of these tests failed out of 7735 tests total - is this expected, or is something misconfigured with my setup? I can provide additional details about the failures if it helps.

Also, I was wondering if I missed something in the Ant build at the root - I only see 4 targets, and no test targets (as I mentioned above):

  • IntelliJ IDEA Community Edition
    • all
    • build
    • cleanup
    • init


Last question related to this general subject of the tests in the open source project - is there a public TeamCity continuous integration build for the open source IntelliJ platform code where I can see the build results, including tests?

Thanks in advance!

Colin

3 comments
Comment actions Permalink

Hello Colin,

I recently checked out the source for the community edition and
platform as outlined on the jetbrains.org site
(http://www.jetbrains.org/display/IJOS/Download) and detailed on Check
Out & Build Community Edition
(http://www.jetbrains.org/pages/viewpage.action?pageId=983225).

I successfully built the project via the IDE. Then, as a first step
beyond those detailed in the Check Out & Build Community Edition, I
ran some tests. I didn't see any "Run" Configuations for the tests in
the project or test targets the build file (idea\build.xml - note that
"idea" is my project root folder), so I just ran those in a module -
specifically "All in java-tests" (eg, idea\java\java-tests\testSrc).
However, 4751 of these tests failed out of 7735 tests total - is this
expected, or is something misconfigured with my setup? I can provide
additional details about the failures if it helps.


No, this is of course not expected. Right now we have just 3 tests failing.

Also, I was wondering if I missed something in the Ant build at the
root - I only see 4 targets, and no test targets (as I mentioned
above):

  • IntelliJ IDEA Community Edition * all * build * cleanup * init


I've added a new target that lets you run the tests from the command line
using 'ant test'.

Last question related to this general subject of the tests in the open
source project - is there a public TeamCity continuous integration
build for the open source IntelliJ platform code where I can see the
build results, including tests?


Right now there is no such server; the Community Edition tests run on our
internal server. There should be one probably, but we haven't gotten around
to setting one just yet. :)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks Dmitry!

The new test target you added ran fine and all tests passed. I assume there is some configuration/setup that needs to occur, so running  (at least some of) the tests straight in IntelliJ's JUnit won't work.

Thanks again!

Colin

0
Comment actions Permalink

Hello Colin,

What kind of errors do you get when running from the IDE?

The new test target you added ran fine and all tests passed. I assume
there is some configuration/setup that needs to occur, so running  (at
least some of) the tests straight in IntelliJ's JUnit won't work.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.