junit plugin...

I'm getting the following error when I try to change the settings in the junit plugin. I had manually unzipped it in the plugin directory to get it to work, but it's still throwing the following error. Is there something I'm doing wrong?

All I did was try to change and then save the settings.

alan

java.lang.NullPointerException

at org.intellij.plugins.junit.config.JUnitTestConfiguration.updateRefactorerState(JUnitTestConfiguration.java:115)

at org.intellij.plugins.junit.config.JUnitTestConfiguration.updateInternalState(JUnitTestConfiguration.java:78)

at org.intellij.plugins.config.Config.configChanged(Config.java:68)

at org.intellij.plugins.config.ConfigEditor.apply(ConfigEditor.java:96)

at org.intellij.plugins.junit.config.JUnitTestConfigurable.apply(JUnitTestConfigurable.java:249)

at com.intellij.openapi.options.a.g.d(g.java:163)

at com.intellij.openapi.options.a.g.doOKAction(g.java:40)

at com.intellij.openapi.ui.DialogWrapper$OkAction.actionPerformed(DialogWrapper.java:4)

at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)

at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)

at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)

at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)

at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)

at java.awt.Component.processMouseEvent(Component.java:5100)

at java.awt.Component.processEvent(Component.java:4897)

at java.awt.Container.processEvent(Container.java:1569)

at java.awt.Component.dispatchEventImpl(Component.java:3615)

at java.awt.Container.dispatchEventImpl(Container.java:1627)

at java.awt.Component.dispatchEvent(Component.java:3477)

at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)

at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)

at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)

at java.awt.Container.dispatchEventImpl(Container.java:1613)

at java.awt.Window.dispatchEventImpl(Window.java:1606)

at java.awt.Component.dispatchEvent(Component.java:3477)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)

at com.intellij.ide.q.b(q.java:42)

at com.intellij.ide.q.a(q.java:131)

at com.intellij.ide.q.dispatchEvent(q.java:133)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)

at java.awt.Dialog$1.run(Dialog.java:540)

at java.awt.Dialog.show(Dialog.java:561)

at com.intellij.openapi.ui.DialogWrapper$MyDialog.show(DialogWrapper.java:26)

at com.intellij.openapi.ui.DialogWrapper.show(DialogWrapper.java:286)

at com.intellij.ide.actions.c.c(c.java:30)

at com.intellij.ide.actions.c.a(c.java:16)

at com.intellij.ide.actions.df.actionPerformed(df.java:1)

at com.intellij.openapi.a.b.d.a(d.java:84)

at com.intellij.openapi.a.b.d.b(d.java:66)

at com.intellij.openapi.a.b.d.a(d.java:83)

at com.intellij.ide.q.a(q.java:123)

at com.intellij.ide.q.dispatchEvent(q.java:133)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

3 comments
Comment actions Permalink

Actually it's the unitTest plugin, not the junitgenerator. Please excuse the confusion

0
Comment actions Permalink

What plugin and IDEA version/build number do you use.
Were you trying to save the settings for the default settings or a project settings?

I am sorry but I am in vacation and won't be able to test the plugin with the newest version of the EAP until later next week.

Jacques

0
Comment actions Permalink

Actually I'm using the production build (4.0.3) of aurora. Is unitTest not supported on Aurora anymore?

I was just trying to save the settings for the default (I can't be certain as I've had to uninstall it for the moment). I hadn't specified either project or default, so I assume the default was to save them as the default settings.

alan

0

Please sign in to leave a comment.