No nightlies for 2016.2 EAP

I upgraded to 2016.2 EAP and my plugin version is stuck at 3.0.425, when the nightlies page offers 3.0.442 already.

I did verify I have "Nightlies" plugin update channel selected.

3 comments
Comment actions Permalink

I tried to force install 3.0.442 and it didn't work. So I guess it is not compatible yet. Moving back to 2016.1.x.

0
Comment actions Permalink

Hello Piotr. Actually we provide Release/EAP/Nightly Scala plugin builds for 2016.2 EAP. And after IDEA upgrade IDE proposes to update Scala plugin considering a channel that you had right before.

I've created for following processing of this topic: https://youtrack.jetbrains.com/issue/SCL-10375

Could you please specify there, which steps you did to get this issue? It's interesting to know, did you uninstall previous version of IDEA, did you import s set of settings etc. Trying several scenarios we could not reproduce this error: at the moment in all cases IDE updates Scala plugin correctly.

>> I tried to force install 3.0.442 and it didn't work

That's correct behavior. Scala plugin 3.0.442 is aimed for 2016.1.x. and is not compatible with 2016.2.

0
Comment actions Permalink

I get nightlies for 2016.2 now, after upgrading IDEA 2016.2 again soon after starting this thread. It looks like the issue automatically fixed itself.

As for how did I get this problem - I just installed 2016.2 from the freshly downloaded tgz and, when asked on starup about importing my 2016.1 settings, I replied "yes".

0

Please sign in to leave a comment.