Problems with JUnit plugin and build 2002


Anyone else having problems with the junit plugin in build 2002?

-- Glen


5 comments
Comment actions Permalink

Hello Glen,

GS> Anyone else having problems with the junit plugin in build 2002?
GS>

What kind of problems?

Jacques

0
Comment actions Permalink

I'm having problems with 2008.

  • The templates didn't get promoted to file template screen.

  • I recreated the ones I have in 4.0.2, but junit won't "see" them. it dies with a "null".

  • I created copies with different names, and associated the junit test class/method with the new names, but it still wants to use the old names, which it can't find.

0
Comment actions Permalink

Hi,
Jacques the problem is in the velocity.init() after setting the extended properties, basically it throws ClassNotFoundException, it cannot find the custom class resource loader or the logWrapper, seems like class loader issue, any ideas on a solution?

Bronwen

0
Comment actions Permalink

Hi,

If you place the velocity.jar found in /lib into the junitTest plugins lib dir ]]>/plugins/unitTest/lib it will work.

Jacques do you think the velocity.jar should be included now with the download?

regards
Bronwen

0
Comment actions Permalink

Sounds like it, Bronwen. Good work!

Jacques

Hi,

If you place the velocity.jar found in <idea home>/lib into the
junitTest plugins lib dir <idea home>/plugins/unitTest/lib it will
work.

Jacques do you think the velocity.jar should be included now with the
download?

regards
Bronwen


0

Please sign in to leave a comment.