IntelliJ v9 sandbox crash?

When I run my plugin, the new instance of IntelliJ freezes. I disabled all the plugins I don't need, except for some JEE support. But as soon as the indexing process ends, opening the project settings (ctrl-alt-shift-S) will cause IDEA to freeze solid. The only thing it's doing is burning up my CPU for 100% flat.

I even tried to create an empty plugin that does nothing, just an almost empty plugin.xml, with no functionality whatsoever, but the new instance freezes.  The "regular" instance, ie the one I start on my desktop runs fine. This never happened in 8. I know it's a bit vague, but that's all I have to work with... Any ideas?

The freeze will sometimes generate this log:

009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA 9.0  Build #IU-93.13
2009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.6.0_17
2009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) 64-Bit Server VM
2009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems Inc.
2009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - OS: Linux
2009-12-09 16:58:09,929 [  54262]  ERROR - com.intellij.ide.IdeEventQueue - Last Action: ShowProjectStructureSettings
2009-12-09 16:58:10,805 [  55138]  ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.diagnostic.DialogAppender$1@7fde1684,notifier=null,catchExceptions=false,when=1260374289928] on sun.awt.X11.XToolkit@13216ee9
java.lang.OutOfMemoryError: PermGen space

So I increased the PermGen space in the debug configuration. This is the commandline that is generated from that debug configuration:

/usr/local/java/jdk1.6.0_17/bin/java -classic -Xdebug -Xrunjdwp:transport=dt_socket,address=127.0.0.1:46140,suspend=y,server=n -Xbootclasspath/a:/usr/local/IntelliJ-9/lib/boot.jar -Didea.config.path=/home/warner/.IntelliJIdea90/system/plugins-sandbox/config -Didea.system.path=/home/warner/.IntelliJIdea90/system/plugins-sandbox/system -Didea.plugins.path=/home/warner/.IntelliJIdea90/system/plugins-sandbox/plugins -Dfile.encoding=UTF-8 -classpath /usr/local/java/jdk1.6.0_17/lib/tools.jar:/usr/local/IntelliJ-9/lib/idea_rt.jar:/usr/local/IntelliJ-9/lib/idea.jar:/usr/local/IntelliJ-9/lib/bootstrap.jar:/usr/local/IntelliJ-9/lib/extensions.jar:/usr/local/IntelliJ-9/lib/util.jar:/usr/local/IntelliJ-9/lib/openapi.jar:/usr/local/IntelliJ-9/lib/jdom.jar:/usr/local/IntelliJ-9/lib/log4j.jar com.intellij.idea.Main -Xms256m -Xmx3g -XX:PermSize=64m -XX:MaxPermSize=512m -ea -server

This is *exactly* the same VM configuration that my main IntelliJ enviroment is running on through idea.vmoptions.

I also have deleted the cache dir, in fact, I have even deleted the entire plugin-sandbox dir. Didn't work

I am quite clueless as for why v9 won't run plugins here....

Cheers,

WarnerJan

2 comments
Comment actions Permalink

Hello WarnerJan,

The 64m of PermGen space is not sufficient for running IDEA or its plugins.
Please give it at least 100m.

When I run my plugin, the new instance of IntelliJ freezes. I disabled
all the plugins I don't need, except for some JEE support. But as soon
as the indexing process ends, opening the project settings
(ctrl-alt-shift-S) will cause IDEA to freeze solid. The only thing
it's doing is burning up my CPU for 100% flat.

I even tried to create an empty plugin that does nothing, just an
almost empty plugin.xml, with no functionality whatsoever, but the new
instance freezes.  The "regular" instance, ie the one I start on my
desktop runs fine. This never happened in 8. I know it's a bit vague,
but that's all I have to work with... Any ideas?

The freeze will sometimes generate this log:

009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - IntelliJ IDEA 9.0  Build #IU-93.13
2009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - JDK: 1.6.0_17
2009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) 64-Bit Server VM
2009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems Inc.
2009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - OS: Linux
2009-12-09 16:58:09,929   ERROR -
com.intellij.ide.IdeEventQueue - Last Action:
ShowProjectStructureSettings
2009-12-09 16:58:10,805   ERROR -
com.intellij.ide.IdeEventQueue - Error during dispatching of
java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intelli
j.diagnostic.DialogAppender$1@7fde1684,notifier=null,catchExceptions=f
alse,when=1260374289928] on sun.awt.X11.XToolkit@13216ee9
java.lang.OutOfMemoryError: PermGen space
So I increased the PermGen space in the debug configuration. This is
the commandline that is generated from that debug configuration:

/usr/local/java/jdk1.6.0_17/bin/java -classic -Xdebug
-Xrunjdwp:transport=dt_socket,address=127.0.0.1:46140,suspend=y,server
=n -Xbootclasspath/a:/usr/local/IntelliJ-9/lib/boot.jar
-Didea.config.path=/home/warner/.IntelliJIdea90/system/plugins-sandbox
/config
-Didea.system.path=/home/warner/.IntelliJIdea90/system/plugins-sandbox
/system
-Didea.plugins.path=/home/warner/.IntelliJIdea90/system/plugins-sandbo
x/plugins -Dfile.encoding=UTF-8 -classpath
/usr/local/java/jdk1.6.0_17/lib/tools.jar:/usr/local/IntelliJ-9/lib/id
ea_rt.jar:/usr/local/IntelliJ-9/lib/idea.jar:/usr/local/IntelliJ-9/lib
/bootstrap.jar:/usr/local/IntelliJ-9/lib/extensions.jar:/usr/local/Int
elliJ-9/lib/util.jar:/usr/local/IntelliJ-9/lib/openapi.jar:/usr/local/
IntelliJ-9/lib/jdom.jar:/usr/local/IntelliJ-9/lib/log4j.jar
com.intellij.idea.Main *-Xms256m -Xmx3g -XX:PermSize=64m
-XX:MaxPermSize=512m -ea -server*

This is exactly the same VM configuration that my main IntelliJ
enviroment is running on through idea.vmoptions.

I also have deleted the cache dir, in fact, I have even deleted the
entire plugin-sandbox dir. Didn't work

I am quite clueless as for why v9 won't run plugins here....

Cheers,

WarnerJan

---
Original message URL:
http://www.jetbrains.net/devnet/message/5252164#5252164

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

OK, please join me in a game "SPOT THE NOOB!!". Everybody please point their index finger towards me!!

My attempts to fiddle around with the memory settings were futile from the start. As you can see from the posted commandline,  the VM parameters were at the back of the commandline, instead of at the front. This means I have entered this stuff in the "program parameters" textfield, instead of the "VM parameters" textfield....  I know... Don't say anything... It's only this morning I realised it so, please accept my apologies for wasting your time...

Happy coding!

WarnerJan

PS: new idea: add a listener to the program parameters textfield that looks for -X parameters. Then you could suggest it's probably in the wrong box

0

Please sign in to leave a comment.