Database update issue depending on DDL order of the table

Hi all, I've got a very strange issue when i try to update a MySql database table with phpStorm (the problem happens only when i change the values with the in-built table layout and not if i run a textual query).

This is the test table i create (note the "deleted_at" colum that is in the FIRST position in the DDL):

 

and this in the sample data:

I can insert new rows but whe i try to update a row (for example to put "z" in the "data3" field I get this error with no explanation:

If I create a new row and fill the "deleted_at" before the commit of the new row then i can update the row, but if i leave the field at null then i get the error.

The strange thing it's that if i create the same table putting the  "deleted_at" after the other colums the issue never appear:

with the DDL above everything works fine and  I can update the rows

I'm missing something or it's a bug?

thanks in advance, Mattia

3 comments
Comment actions Permalink

This just worked fine on latest PhpStorm EAP build:

and 

Please try to download and install it and check again.

0
Comment actions Permalink

yes it works if you run a textual query but can you try to modify the value directly by the graphical table?in that case I get the error above

0
Comment actions Permalink

Yes, it also works if I just doubleclick the value > enter new value > Enter.

So yeah, please try out latest EAP build.

0

Please sign in to leave a comment.