Spell Checker for 4.0

Is there a Spell checker plug-in for 4.0. I tried the one that you can access via the plug-in manager and it states max version 3.0. I tried it with 4.0 and it did not work..

Any suggestions for 4.0?

7 comments

Hi,
I recompiled the plugin source code with the new Intellij and it worked fine.

Ziad

0

Hi,
I tried building with 4.0 and it seemed to compile, and deploy OK, but I can't get it to work.

I have spell check icon in the preferences/properties pane, but clicking on it does nothing.

I don't see how to invoke the spell checker from within IDEA.

Any tips appreciated. Thanks, Spencer

0

OK, I dug a little and got it work.

Thing one:

I found how invoke the spell checker - from the code menu - not from the right click menu or tool menu where I looked. (Note: yes, this is another example of value of RTFMing - although putting this documentation in the distribution would have been helpful - I did look there first).

Thing two:

I could not figure out how to configure the dictionary placement. By default, when the spell checker is invoked it wants to look at idea.home/plugins/dictionary but the ant deploy task puts stuff in idea.home/plugins/spellchecker-projectname/dictionary
I could figure out how/where to change this setting (I only spent a few minutes on it.
My work around hack was to copy the folder: idea.home/plugins/spellchecker-projectname/dictionary
to here:
idea.home/plugins/dictionary
Once I did that it just worked.
--
What is the policy for updating plugins on the wiki? If I can figure out how to change the default location of where the dictionaries are looked for I could recompile this guy and post the binaries - if that is acceptable as it looks like the original author doesn't intend to update it for 4.0.

0

You could also press CTRLSHIFTS to run the spell checker

0

Ron Lamb wrote:

Is there a Spell checker plug-in for 4.0. I tried the one that you can access via the plug-in manager and it states max version 3.0. I tried it with 4.0 and it did not work..

Any suggestions for 4.0?


Hi original author here, I admit to being a bit slow with updating the plugin,
honestly you guys are the first I've seen that have expressed interest and I'm
pretty surprised the code works at all under Idea 4.0.
I was hoping for more documentation on migrating plugins and the new development
framework for plugin development.
The notes presented here are fairly accurate, the directory structure needs to
be moved to the new location, and the spell checker is invoked from tools and
the hotkey - but they're s also a configuration dialog which should appear under
preferences - which is obviously failing under 4.0. I'll see what I can do by
means of an update, but I'm in the middle of a relocation at the moment so my
spare time is spoken for.. help is always appreciated, especially any pointers
in respect to what needs changing in migration to 4.0.

- Richard

0

Thanks, I've been using it for a couple of days with no problem (once I fixed the install bit). It's great - no more cutting pasting comments back and forth from idea.

Thanks for taking the effort to make this available. If you need help let me know I'd be happy to.

0

Richard Osbaldeston wrote:

Rebuilt the source for Idea 4.0; cant see how any of you guys did this before
as the OpenApi object used dont exsit anymore..?

ABSOLUTELY cant attach the new distribution, to the plugin page!! been trying
for 45 minutes now (1.40am!!) and keep hitting "Internal Error" from the
IntelliJ server.. no matter how many times I try.. lousy Wiki ?#@!#!!.. mutter
mutter..

Uploading to:

http://www.osbald.co.uk/java/tips/SpellCheckPlugin05.zip

and

http://www.osbald.co.uk/java/tips/SpellCheckPlugin05-src.zip

until someone fixes this.

- Richard

0

Please sign in to leave a comment.