trouble compiling JarSpy for 4.0 ->class file has wrong version 48.0, should be 47.0

Hi,

I thought I'd try compiling JarSpy for 4.0, but encountered this problem:

class file has wrong version 48.0, should be 47.0 (complete error below).

Grepping around the forumn here, I discovered this problem might be related to JAD as a saw thread that attributed this error to JAD staleness, however, I am not sure how just compiling sources triggers this problem.

In any case, if anyone has any pointer for me, I will try to compile / make a 4.0 of JarSpy and try to get it published for 4.0.

Thanks, Spencer




C:\sam\local-projects\JarSpy\src\com\ociweb\jarspy\intellij\plugin\JarSpyIntelliJPlugin.java
Error: line (22) cannot access com.intellij.openapi.wm.ToolWindowManager
C:/sam/local-projects/JarSpy/src/com/ociweb/jarspy/intellij/plugin/JarSpyIntelliJPlugin.java:22: cannot access com.intellij.openapi.wm.ToolWindowManager
bad class file: C:\sam\local-projects\JarSpy\lib\openapi.jar(com/intellij/openapi/wm/ToolWindowManager.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

Please sign in to leave a comment.