Anybody get the Visual Paradigm plugin working with IDEA 4?

I've followed their directions to install their plugin, and I always get the message "In order to complete the SDE CI-IJ installation, please restart your IntelliJ IDEA", regardless of how many times I restart IDEA. I'm using the most recent version of IDEA. Has anyone successfully gotten this plugin working?

Thanks...

4 comments

I downloaded the ZIP version (no install) and followed the instructions.
Opened IDEA without any project, setup few things for a new unnamed
project and then restarted the IDEA. Everything worked since then.
Please, look at the documentation, it may help ;)

Also, someone asked about the level of integration...
There is no refactoring-level integration - if you reverse engineer
a set of classes and then rename a method in class diagram, the
code will change but it would be simple rename, not refactored rename.
(BTW, any code integration is possible only in the $600 version)

One thing that I miss in EVERY UML tool is better keyboard navigation.
That's also true for VP/SDE.

r.

Aaron Whittier wrote:

I've followed their directions to install their plugin, and I always get the
message "In order to complete the SDE CI-IJ installation, please restart your
IntelliJ IDEA", regardless of how many times I restart IDEA. I'm using the
most recent version of IDEA. Has anyone successfully gotten this plugin
working?

Thanks...

0

Ok, I followed the documentation, no luck. Here is precisely what I've done; let me know where it deviates from what worked for you:

1) Downloaded the plugin's ZIP,
2) Unpacked the ZIP directly into the IDEA home directory (ie the vp_windows and vp_help directories are unpacked into IDEA\bin; sdeIJ is unpacked into IDEA\plugins),
3) Started IDEA, saw the "please restart" dialog,
4) Created a new project, just in case there was some weird voodoo involved in doing so, then
5) Closed and restarted IDEA.

At this point, the dialog popped up again telling me to restart IDEA. All the context menus, all the stuff under the main Tools menu, the entry in the plugins settings page are all there, but I can't use any of it without getting errors about needing to restart IDEA. Neither rebooting my machine nor restarting IDEA several times seems to make any difference. What did you do differently? Were you using an older version of 4.0, maybe an EAP or something?

Thanks...

0

What platform are you running IDEA on? On Windows XP I simply downloaded the SDE exe file and installed it. Went in first time with no problems and only one restart of IDEA necessary.

0

Aaron Whittier wrote:

Ok, I followed the documentation, no luck. Here is precisely what I've done;
let me know where it deviates from what worked for you:


What I did was almost same, except that I closed all projects and
after restart IDEA offered the new project wizard (that was closest
behavior to what was in the docs). Only then, I created a new dummy
Java project - exactly following the user guide.

r.

0

Please sign in to leave a comment.