Question about <change-notes>, memory-leak, updated plugin-infos...

Hi.

I just submitted the latest version of my plugin (thanks again for the
help) but strangely my don't show up on the plugin page. http://plugins.intellij.net/plugin/?id=2176 They look like this in plugin.xml:

  • 0.0.3 - 2008-11-17
    • Updated to support both IDEA 7 and IDEA 8.
    • Only accepting connections from 127.0.0.1.
  • 0.0.2 - 2008-04-06
    • Fixed problem with anonymous classes.
    • Now building against IDEA 1.5 SDK so this should work on Mac, too.
  • 0.0.1 - 2008-04-04
    • Initial release.
  • \]\]\> ]]>

    This worked for the previous version.

    Also, I get the following message after exiting the Plugin-Instance of
    IDEA, i.e. the one that is started to test the plugin:
    ***********************************************************************************************

        • M E M O R Y L E A K S D E T E C T E D

    ***
    ***********************************************************************************************
    ***
    ***

        • The following objects were not disposed:

    ***
    com.intellij.ide.structureView.newStructureView.StructureViewComponent[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
    of class class
    com.intellij.ide.structureView.newStructureView.StructureViewComponent
    ***
    com.intellij.ide.structureView.newStructureView.StructureViewComponent[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
    of class class
    com.intellij.ide.structureView.newStructureView.StructureViewComponent
    ***
    com.intellij.ide.structureView.newStructureView.StructureViewComponent[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
    of class class
    com.intellij.ide.structureView.newStructureView.StructureViewComponent
    ***
    com.intellij.ide.structureView.newStructureView.StructureViewComponent[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
    of class class
    com.intellij.ide.structureView.newStructureView.StructureViewComponent
    ***
    ***
    ***********************************************************************************************

    I have absolutely no idea how my code might create a memory leak. You
    can take a look at my code at
    http://lilith.svn.sourceforge.net/viewvc/lilith/trunk/lilith-idea-plugin/
    It's actually quite trivial...

    Beside that, the infos I added on the "Update plugin" page don't show up
    on the plugin page. I changed from free software to open source and
    provided links to repository, license and bug-tracker but neither show
    up on the plugin page.

    I hope this isn't the wrong newsgroup for those questions. If this is
    the case, please point me to a better one.

    Thanks,
    Joern.

    2 comments
    Comment actions Permalink

    you probably have some issue with caches, as I can see

    Vendor: Huxhorn

    Email: contact@lilith.huxhorn.de

    Website: http://lilith.huxhorn.de/idea

    License: license url

    Bugtracker page
    (with the link to http://sourceforge.net/tracker2/?group_id=219536)

    Concerning the change notes though I don't see them either, nor can i see them in the IDEA plugin manager (version 0.0.3 right ?)

    0
    Comment actions Permalink

    Thibaut wrote:

    you probably have some issue with caches, as I can see

    Vendor: Huxhorn

    Email: contact@lilith.huxhorn.de

    Website: http://lilith.huxhorn.de/idea

    License: license url

    Bugtracker page
    (with the link to http://sourceforge.net/tracker2/?group_id=219536)

    Concerning the change notes though I don't see them either, nor can i see them in the IDEA plugin manager (version 0.0.3 right ?)


    Yes, I was later able to change the license and bugtracker url, but only
    one info at a time...? So there's probably a problem with the "Update
    plugin" form right now.

    I don't understand the change notes problem, though. I added them to the
    usage info in the meantime.

    Yes, 0.0.3 is the right version.

    Joern.

    0

    Please sign in to leave a comment.