IDEA 8 and IntelliJ IDEA SDKs from earlier IDEA versions

Should I be able to use IDEA 8 to develop a plug-in that targets earlier
versions of IDEA e.g. where plug-in modules specify an IDEA 7 SDK? I'm
seeing OpenAPI classes highlighted as errors with this configuration.

I'm fairly sure IDEA 7 was happy with IDEA 5 & 6 SDKs.

--
Mark Scott
mark@codebrewer.com

3 comments
Comment actions Permalink

Hello Mark,

Should I be able to use IDEA 8 to develop a plug-in that targets
earlier versions of IDEA e.g. where plug-in modules specify an IDEA 7
SDK? I'm seeing OpenAPI classes highlighted as errors with this
configuration.


Yes, you should be able to do that. You may need to add idea.jar to the SDK
classpath.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I was missing lib/util.jar (class: IconLoader).

0
Comment actions Permalink

On Mon, 10 Nov 2008 11:01:11 +0000, Dmitry Jemerov wrote:

Hi Dmitry,

>> Should I be able to use IDEA 8 to develop a plug-in that targets
>> earlier versions of IDEA


Yes, you should be able to do that. You may need to add idea.jar to the
SDK classpath.


It turned out that my IntelliJ IDEA SDK didn't have any IDEA jar files
attached to it i.e. it contained only the dozen or so from the Sun JDK
and none of the 50 or so from IDEA. I certainly didn't delete any
entries, and the plug-in devkit was installed correctly (and no, it
wasn't a case of mistakenly creating a JSDK rather than an IDEA SDK).
Recreating the IDEA SDK fixed the problem. Weird.

--
Mark Scott
mark@codebrewer.com

0

Please sign in to leave a comment.