Orion plugin error when debugging under 1117

Hey Hani,

Noticed this for the first time in 1113 and it's happens in 1117 as well
using the latest and greatest Orion plugin. Don't know if this is
anything you can control since it looks like it's choking in the
OpenAPI.

java.lang.Throwable
at
com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:60)
at
com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:97)
at
com.intellij.util.LaterInvocator.invokeAndWait(LaterInvocator.java:9)
at
com.intellij.openapi.j2ee.web.impl.JSR45JspDebugSupport.]]>(JSR45JspD
ebugSupport.java:21)
at
com.ironflare.idea.web.OrionIntegration$1$1.run(OrionIntegration.java:10
7)
at
com.intellij.openapi.application.b.b.runWriteAction(b.java:96)
at
com.ironflare.idea.web.OrionIntegration$1.run(OrionIntegration.java:96)
at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)

I'm not attempting to debug a JSP so I don't know what it thinks it's
doing. I've hooked into my Orion 2.0.2 session remotely and have simply
loaded up a page that hit a couple Struts actions. I don't have any
breakpoints set.

This ends up hanging IDEA which is sort of unfortunate.

Thanks,
Martin


3 comments
Comment actions Permalink

Yeah unfortunately orion 2.0.2 doesn't support JSR45 debugging (the next major version will though), in my tests though generally that just gets ignored and everything runs fine.

I've just uploaded a new version that works with 1120, and will poke around and see if I can reproduce/fix your error. Thanks for the feedback!

0
Comment actions Permalink

Thanks for the very fast fix Hani,

That did the trick. Thanks for saving me from having to go back to
using version 3.0.

Martin

--

Martin Saxer

"Hani Suleiman" <hani@formicary.net> wrote in message
news:6246666.1074977222813.JavaMail.itn@is.intellij.net...

Yeah unfortunately orion 2.0.2 doesn't support JSR45 debugging (the

next major version will though), in my tests though generally that just
gets ignored and everything runs fine.
>

I've just uploaded a new version that works with 1120, and will poke

around and see if I can reproduce/fix your error. Thanks for the
feedback!


0

Please sign in to leave a comment.