5 comments
Comment actions Permalink

Hello and thanks for an excellent plugin.

It doesn't however seem to work with 1035:

java.lang.LinkageError: Class com/intellij/openapi/editor/Editor
violates loader constraints
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
at java.lang.ClassLoader.defineClass(ClassLoader.java:448)
at com.intellij.ide.plugins.a.a.a(a.java:25)
at com.intellij.ide.plugins.a.a.findClass(a.java:12)
at com.intellij.ide.plugins.a.c.loadClass(c.java:1)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
at com.maddyhome.idea.vim.KeyHandler.handleKey(KeyHandler.java:340)
at
com.maddyhome.idea.vim.VimTypedActionHandler.execute(VimTypedActionHandler.java:72)
at
com.intellij.openapi.editor.actionSystem.TypedAction$2.run(TypedAction.java)
at com.intellij.openapi.application.b.b.runWriteAction(b.java:197)
at
com.intellij.openapi.editor.actionSystem.TypedAction$1.run(TypedAction.java:4)
at com.intellij.openapi.command.impl.a.executeCommand(a.java:71)
at
com.intellij.openapi.editor.actionSystem.TypedAction.actionPerformed(TypedAction.java:3)
at com.intellij.openapi.editor.b.m.a(m.java:17)
at com.intellij.openapi.editor.b.m.access$700(m.java:983)
at com.intellij.openapi.editor.b.m$42.keyTyped(m$42.java:9)
at java.awt.Component.processKeyEvent(Component.java:5055)
at javax.swing.JComponent.processKeyEvent(JComponent.java:2388)
at java.awt.Component.processEvent(Component.java:4909)
at java.awt.Container.processEvent(Container.java:1569)
at java.awt.Component.dispatchEventImpl(Component.java:3615)
at java.awt.Container.dispatchEventImpl(Container.java:1627)
at java.awt.Component.dispatchEvent(Component.java:3477)
at
java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1713)
at
java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:627)
at
java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:831)
at
java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:741)
at
java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:592)
at java.awt.Component.dispatchEventImpl(Component.java:3506)
at java.awt.Container.dispatchEventImpl(Container.java:1627)
at java.awt.Window.dispatchEventImpl(Window.java:1606)
at java.awt.Component.dispatchEvent(Component.java:3477)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
at com.intellij.ide.q.b(q.java:11)
at com.intellij.ide.q.a(q.java:39)
at com.intellij.ide.q.dispatchEvent(q.java:141)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)


Best regards,

Maron Kristofersson


Rick Maddy wrote:

Support for Aurora #992 and higher. Use the plugin manager to update/install.


0
Comment actions Permalink

It (1035) is working fine for me. Though I installed it by getting 1035 with no JRE then copied the JRE from 1024 and copied the plugins from 1024.

I have not tried with the full installer of 1035. All of this was done under Linux.

0
Comment actions Permalink

Thanks for the quick reply!

I tried getting 1035 with no JRE and used the JRE from 1019 (don't have
1025). I am getting the same errors as before. I downloaded the plugin
with the plugin manager and am running RH Linux 9. I tried downloading
the source and looking through it, but didn't spot any obvious problems.

Regards,

Maron

Rick Maddy wrote:

It (1035) is working fine for me. Though I installed it by getting 1035 with no JRE then copied the JRE from 1024 and copied the plugins from 1024.

I have not tried with the full installer of 1035. All of this was done under Linux.


0
Comment actions Permalink

Hello again!

Just tried building the .jar file from source. That one works fine.

Regards,

Maron

Rick Maddy wrote:

It (1035) is working fine for me. Though I installed it by getting 1035 with no JRE then copied the JRE from 1024 and copied the plugins from 1024.

I have not tried with the full installer of 1035. All of this was done under Linux.


0
Comment actions Permalink

I confirmed the problem when downloading the full 1035 install. Strange.

I just released 0.6.4 of the VIM plugin. It works fine under 1035.

Rick

0

Please sign in to leave a comment.