[ANN] IdeaJad for 963 released

Hi,

as usual you can find the the release at http://www.tagtraum.com/

Let me know if something went wrong.

Cheers,

-hendrik

PS: Note that this release requires Aurora - it will not run with 3.0.5

IdeaJad 963.1
=============
- Fixed decompile jar bug
- Added jad executable for MacOSX
- Unix jad executables are now made executable
automatically
- Changed the name of the jar to not include the
version number anymore (which was really annoying
when updating)

10 comments


is there a chance that JAD will be updated ?

0

 and 47.0 are supported)]]>


is there a chance that JAD will be updated ?


Probably not - however, in most cases jad complains, but does the work nevertheless.

-hendrik

0

One issue, not sure if I mentioned it yet:
I would like the option to make decompiled classes read-only,
but have the plugin still overwrite them without complaining.
(I'd like them R-O for everyone but the plugin).

Hendrik Schreiber wrote:

Hi,

as usual you can find the the release at http://www.tagtraum.com/

Let me know if something went wrong.

Cheers,

-hendrik

PS: Note that this release requires Aurora - it will not run with 3.0.5

IdeaJad 963.1
=============
- Fixed decompile jar bug
- Added jad executable for MacOSX
- Unix jad executables are now made executable
automatically
- Changed the name of the jar to not include the
version number anymore (which was really annoying
when updating)


--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0

put in PluginManager?

Hendrik Schreiber wrote:

Hi,

as usual you can find the the release at http://www.tagtraum.com/

Let me know if something went wrong.

Cheers,

-hendrik

PS: Note that this release requires Aurora - it will not run with 3.0.5

IdeaJad 963.1
=============
- Fixed decompile jar bug
- Added jad executable for MacOSX
- Unix jad executables are now made executable
automatically
- Changed the name of the jar to not include the
version number anymore (which was really annoying
when updating)


--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0

hm - for the whole jar that might be difficult as I rely in wildcards and jad. For single files this might be doable... let me think about it for a while...

-hendrik

0

PluginManager? You lost me...

-hendrik

0

please see

plugins.intellij.net

and

Tools --> Plugin Manager

0

I wasn't aware of the site.... seems to make sense... I guess that's means I have to fix that build error that leads to the fancy version number "@version@" :)

Up till now, some of the entries in the plugin descriptor seemed cosmetic...

So: Question!

What versions should a plugin claim to support, if it only supports current Aurora releases, but 3.0.5 anymore?

Also: will there be a real plugin manager built into IntellijIdea, that automatically downloads plugins? What about security? Malicious plugins? Will they run within a special security context/sandbox?

-hendrik

0

So: Question!

What versions should a plugin claim to support, if it
only supports current Aurora releases, but not 3.0.5
anymore?

Also: will there be a real plugin manager built into
IntellijIdea, that automatically downloads plugins?
What about security? Malicious plugins? Will they run
within a special security context/sandbox?


Has this been answered somewhere else? Could someone from JetBrains please comment?

Thanks,

-hendrik

PS: For those who care - hope y'all had a great Thanksgiving!

0

Please sign in to leave a comment.