Error in builtin Graph library

In writing my new CVS Revision Graph plugin, I am unable to get it to work under IntelliJ 6. IntelliJ 7 can use it OK, however, IntelliJ 6 gives me an error when I try to add a Graph2DSelectionListener to my Graph2D. It throws an exception stating it is unable to unwrap the interface a/b/dd or something like that. Investigating a little more, I can see that adding a selection listener to a graph calls GraphBase.unwrap. It must be failing there for some reason. This should not happen since the object I pass in does implement the Graph2DSelectionListener interface.

2 comments
Comment actions Permalink

Graph2DSelectionListener bug was fixed in the end of January, 2007 after
IntelliJ 6 had been released.

In writing my new CVS Revision Graph plugin, I am unable to get it to
work under IntelliJ 6. IntelliJ 7 can use it OK, however, IntelliJ 6
gives me an error when I try to add a Graph2DSelectionListener to my
Graph2D. It throws an exception stating it is unable to unwrap the
interface a/b/dd or something like that. Investigating a little more,
I can see that adding a selection listener to a graph calls
GraphBase.unwrap. It must be failing there for some reason. This
should not happen since the object I pass in does implement the
Graph2DSelectionListener interface.



0
Comment actions Permalink

Then how am I supposed to support IntelliJ 6 with my new CVS Revision Graph plugin? A lot of people don't have or want to buy version 7, but I would like for them to have access to my plugin that requires graph selection.

0

Please sign in to leave a comment.