JAD plugin and build 922

I used to run jad 813-1 plugin. I installed 922 fresh and encountered an
error. I removed the jad plugin and did not get an error. I downloaded jad
887-1 plugin and still got an error.

ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching
of
java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.open
api.
project.a.s@1a05ea4,notifier=null,catchExceptions=false,when=1063112505393]
on s
un.awt.windows.WToolkit@1a5930e
ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA (Aurora)
Bui
ld #922
ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.4.2
ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM)
Client
VM
ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems
Inc
.
ERROR - com.intellij.ide.IdeEventQueue - OS: Windows 2000
ERROR - com.intellij.ide.IdeEventQueue - Last Action:
ERROR - com.intellij.ide.IdeEventQueue -
java.lang.AbstractMethodError
at com.intellij.openapi.fileEditor.a.m.c(m.java:49)
at com.intellij.openapi.fileEditor.a.m.b(m.java:68)
at com.intellij.openapi.fileEditor.a.m.a(m.java:202)
at com.intellij.openapi.fileEditor.a.bb.run(bb.java:1)
at com.intellij.openapi.command.b.b.executeCommand(b.java:12)
at com.intellij.openapi.fileEditor.a.m.a(m.java:437)
at com.intellij.openapi.fileEditor.a.m.b(m.java:93)
at com.intellij.openapi.fileEditor.a.bd.run(bd.java:7)
at com.intellij.openapi.command.b.b.executeCommand(b.java:77)
at com.intellij.openapi.fileEditor.a.bc.run(bc.java:3)
at com.intellij.ide.q.a.b.e(b.java:3)
at com.intellij.ide.q.a.b.d(b.java:36)
at com.intellij.openapi.project.a.s.run(s.java:2)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.s.a(s.java:46)
at com.intellij.ide.s.dispatchEvent(s.java:82)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog.show(Unknown Source)
at
com.intellij.openapi.ui.DialogWrapper$MyDialog.show(DialogWrapper.jav
a:18)
at com.intellij.openapi.ui.DialogWrapper.show(DialogWrapper.java:93)
at com.intellij.progress.a.j.run(j.java:1)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.s.a(s.java:46)
at com.intellij.ide.s.dispatchEvent(s.java:82)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)



3 comments
Comment actions Permalink

Hello,

The open API in the package com.intellij.openapi.fileEditor.* has been
changed in the build 922. Some plugins may not work properly and cause IDEA
to crash.

If you encounter such problems couldn't you please remove problematic
plugins until their vendors reflect the changes in API.

Sorry for inconvenience.

--
Best regards,
Anton Katilin
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


--
Best regards,
Anton Katilin
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Norris Shelton" <nshelton@appriss.com> wrote in message
news:bjkj51$29d$1@is.intellij.net...

I used to run jad 813-1 plugin. I installed 922 fresh and encountered an
error. I removed the jad plugin and did not get an error. I downloaded

jad

887-1 plugin and still got an error.

>

ERROR - com.intellij.ide.IdeEventQueue - Error during

dispatching

of

>
java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.open

api.

>
project.a.s@1a05ea4,notifier=null,catchExceptions=false,when=1063112505393]

on s
un.awt.windows.WToolkit@1a5930e
ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA (Aurora)
Bui
ld #922
ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.4.2
ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM)
Client
VM
ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun

Microsystems

Inc
.
ERROR - com.intellij.ide.IdeEventQueue - OS: Windows 2000
ERROR - com.intellij.ide.IdeEventQueue - Last Action:
ERROR - com.intellij.ide.IdeEventQueue -
java.lang.AbstractMethodError
at com.intellij.openapi.fileEditor.a.m.c(m.java:49)
at com.intellij.openapi.fileEditor.a.m.b(m.java:68)
at com.intellij.openapi.fileEditor.a.m.a(m.java:202)
at com.intellij.openapi.fileEditor.a.bb.run(bb.java:1)
at com.intellij.openapi.command.b.b.executeCommand(b.java:12)
at com.intellij.openapi.fileEditor.a.m.a(m.java:437)
at com.intellij.openapi.fileEditor.a.m.b(m.java:93)
at com.intellij.openapi.fileEditor.a.bd.run(bd.java:7)
at com.intellij.openapi.command.b.b.executeCommand(b.java:77)
at com.intellij.openapi.fileEditor.a.bc.run(bc.java:3)
at com.intellij.ide.q.a.b.e(b.java:3)
at com.intellij.ide.q.a.b.d(b.java:36)
at com.intellij.openapi.project.a.s.run(s.java:2)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.s.a(s.java:46)
at com.intellij.ide.s.dispatchEvent(s.java:82)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
Source)

>

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog.show(Unknown Source)
at
com.intellij.openapi.ui.DialogWrapper$MyDialog.show(DialogWrapper.jav
a:18)
at

com.intellij.openapi.ui.DialogWrapper.show(DialogWrapper.java:93)

at com.intellij.progress.a.j.run(j.java:1)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.s.a(s.java:46)
at com.intellij.ide.s.dispatchEvent(s.java:82)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
Source)

>

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

>
>


0
Comment actions Permalink

Not a problem. Great product.


Anton Katilin (JetBrains) wrote:

Hello,

The open API in the package com.intellij.openapi.fileEditor.* has been
changed in the build 922. Some plugins may not work properly and cause IDEA
to crash.

If you encounter such problems couldn't you please remove problematic
plugins until their vendors reflect the changes in API.

Sorry for inconvenience.


0
Comment actions Permalink

Hi,

I uploaded a new version of the JAD plugin. It was built with 922 and adjusted to the API changes.

If there are future problems with the plugin due to API changes, please drop me a line at hs@tagtraum.com.

Thanks,

-hendrik

=> http://www.tagtraum.com/ideajad.html

0

Please sign in to leave a comment.