CC Plugin with 815

I all,

I'm trying to use the cc plugin with the 815, but i've got problems.

If I use transparent-idea3.5-1.20.jar i get this exception
and i can access only files from one contents src in the explorer and in the other, i can only see the directories, but no java files.



###################net.sourceforge.transparent.TransparentConfiguration@1c2ec05
java.lang.Throwable
at net.sourceforge.transparent.TransparentConfiguration.getInstance(TransparentConfiguration
.java:47)
at net.sourceforge.transparent.TransparentVcs.initComponent(TransparentVcs.java:42)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.getComponents(a.java:133)
at com.intellij.openapi.vcs.a.be.initComponent(be.java:53)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.m(a.java:192)
at com.intellij.openapi.components.b.a.i(a.java:14)
at com.intellij.openapi.project.a.c.w(c.java:41)
at com.intellij.openapi.project.a.d.w(d.java:2)
at com.intellij.openapi.project.a.p.a(p.java:94)
at com.intellij.openapi.fileEditor.b.e.initComponent(e.java:45)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.m(a.java:192)
at com.intellij.openapi.components.b.a.i(a.java:14)
at com.intellij.openapi.application.a.d.a(d.java:94)
at com.intellij.idea.d.b(d.java:42)
at com.intellij.idea.j.run(j.java)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
###################net.sourceforge.transparent.TransparentConfiguration@46a5c4
java.lang.Throwable
at net.sourceforge.transparent.TransparentConfiguration.getInstance(TransparentConfiguration
.java:47)
at net.sourceforge.transparent.TransparentVcs.initComponent(TransparentVcs.java:42)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.getComponents(a.java:133)
at com.intellij.openapi.vcs.a.be.initComponent(be.java:53)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.m(a.java:192)
at com.intellij.openapi.components.b.a.i(a.java:14)
at com.intellij.openapi.project.a.c.w(c.java:41)
at com.intellij.openapi.project.a.d.w(d.java:2)
at com.intellij.openapi.project.a.c.z(c.java:7)
at com.intellij.openapi.project.a.p.b(p.java:0)
at com.intellij.ide.k.q.a(q.java:27)
at com.intellij.idea.d.d(d.java:28)
at com.intellij.idea.d.c(d.java:4)
at com.intellij.idea.e.run(e.java:0)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.t.a(t.java:97)
at com.intellij.ide.t.dispatchEvent(t.java:48)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)




If i use transparent-idea3.0-1.20.jar I get the following exception and the editor never start.

ERROR - intellij.plugins.PluginManager -
ERROR - intellij.plugins.PluginManager - IntelliJ IDEA (Aurora) Build #815
ERROR - intellij.plugins.PluginManager - JDK: 1.4.1_02
ERROR - intellij.plugins.PluginManager - VM: Java HotSpot(TM) Client VM
ERROR - intellij.plugins.PluginManager - Vendor: Sun Microsystems Inc.
ERROR - intellij.plugins.PluginManager - OS: Windows NT
ERROR - intellij.plugins.PluginManager - Last Action:
ERROR - intellij.plugins.PluginManager -
java.lang.IncompatibleClassChangeError: Implementing class
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at com.intellij.ide.j.a.a.a(a.java:4)
at com.intellij.ide.j.a.a.findClass(a.java:17)
at com.intellij.ide.j.a.c.loadClass(c.java:8)
at java.lang.ClassLoader.loadClass(Unknown Source)
at com.intellij.ide.j.a.b.loadClass(b.java:37)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.intellij.openapi.components.b.a.a(a.java:99)
at com.intellij.openapi.project.a.d.b(d.java:146)
at com.intellij.openapi.project.a.p.b(p.java:2)
at com.intellij.openapi.project.a.p.readExternal(p.java:156)
at com.intellij.openapi.components.b.a.a(a.java:36)
at com.intellij.openapi.components.b.a.a(a.java:58)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.project.b.c.a(c.java:1)
at com.intellij.openapi.fileEditor.b.e.initComponent(e.java:45)
at com.intellij.openapi.components.b.a.a(a.java:105)
at com.intellij.openapi.components.b.a.getComponent(a.java:29)
at com.intellij.openapi.components.b.a.m(a.java:192)
at com.intellij.openapi.components.b.a.i(a.java:14)
at com.intellij.openapi.application.a.d.a(d.java:94)
at com.intellij.idea.d.b(d.java:42)
at com.intellij.idea.j.run(j.java)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


Does anybody have problems like this? Does anyone know what's happening?

Thanks

Franck

2 comments

I'm seeing the same errors here.

0

I will work next on upgrading the plugin to 815.
Sorry but if you have to use clearcase stick with 813 for a while.

I just released 1.21 that should be more stable and much better than 1.20 in term of speed.

Jacques

0

Please sign in to leave a comment.