Is there any way to change the name of the standard RenameRefactoring in history?
For example, in my plugin (for batch variables renaming) I invoke it in such way:
RefactoringFactory refactoringFactory = RefactoringFactory.getInstance(project);
renameRefactoring = refactoringFactory.createRename(psiElement, replacement);
Here newElement1 and newElement2 (and psiElement) are different PsiElements(completely different variables).
Then I try to invoke this in Idea, and it works fine usually. But when I press "Undo" button, I got a popup window, and a question there is quite confusing: "Undo renaming variable psiElement to replacement?" ("OK"/"Cancel") instead of something like ""Undo renaming many variables?" Is there any way to replace this message? I know about UndoConfirmationPolicy and CommandProcessor classes, but it seems that I can't use them, because RenameRefactoring seems to put itself in undo/redo history(or maybe I don't understand what should I put in CommandProcessor.executeCommand-method as a groupId). Is there something I am missing?
P.S. Excuse my French :)