Failing to upload my contest plugin

hi,
after passing more than an hour i could not upload my contest plugin :(
mailed to IDea plugin admin, no response yet...
any idea?

HINTS: i am depending on mail.jar, activation.jar and my jar
so i have zipped all together.. and included META-INF/plugins.xml with
my root plugin directory.

best regards

13 comments

Have you used the menu packaging: "Prepare plugin module for
deployment..." (right click in the project browser).

But be patient the contest will last some more days, I'm sure the admin
wil answer then. Perhaps you should publish your archive in the forum,
so others can have a look.

Thomas

hasan wrote:

hi,
after passing more than an hour i could not upload my contest plugin :(
mailed to IDea plugin admin, no response yet...
any idea?

HINTS: i am depending on mail.jar, activation.jar and my jar
so i have zipped all together.. and included META-INF/plugins.xml with
my root plugin directory.

best regards

0

Hi thomas,
i am very eager to share with other...
i will give the URL if the uploading part does not work again.

:D thank you
best regards,

Thomas Hartwig wrote:

Have you used the menu packaging: "Prepare plugin module for
deployment..." (right click in the project browser).

But be patient the contest will last some more days, I'm sure the admin
wil answer then. Perhaps you should publish your archive in the forum,
so others can have a look.

Thomas

hasan wrote:

>> hi,
>> after passing more than an hour i could not upload my contest plugin :(
>> mailed to IDea plugin admin, no response yet...
>> any idea?
>>
>> HINTS: i am depending on mail.jar, activation.jar and my jar
>> so i have zipped all together.. and included META-INF/plugins.xml with
>> my root plugin directory.
>>
>> best regards

0

What the problems? May be any error message?

0

Dmitry Kashin wrote:

What the problems? May be any error message?

hi Dmitry,
i am getting this error message
" Error!
You have specified an invalid distribution package. Please check and try
again."

my package structure:
ROOT.zip
-- Package Dir
-- -


META-INF/plugins
-- -


libs/my plugin, mail, activation etc..*.jar
regards

0

Hi,

First of all I suggest you use next plugin for packaging
http://plugins.intellij.net/plugin/?id=1017 (works only for Demetra)

As for me your structure wrong, it should be like described at http://www.jetbrains.com/idea/plugins/plugin_structure.html

So in your layout missed at least root directory of plugin with classes and lib dir in it.

0

Dmitry Kashin wrote:

Hi,

First of all I suggest you use plugin
http://plugins.intellij.net/plugin/?id=1017 (works only for Demetra)

As for me our structure wrong, it should be like described at http://www.jetbrains.com/idea/plugins/plugin_structure.html

So in your layout missed at least root directory of plugin with classes and lib dir in it.



Hi,
thank you for you prompt reply i am chking now and let u know the update

best regards,

0

Dmitry Kashin wrote:

Hi,

First of all I suggest you use plugin
http://plugins.intellij.net/plugin/?id=1017 (works only for Demetra)

As for me our structure wrong, it should be like described at http://www.jetbrains.com/idea/plugins/plugin_structure.html

So in your layout missed at least root directory of plugin with classes and lib dir in it.

hi,
i have downloaded your plugin but could not run it. :(
i can see the context menu item. but UI is not loading.

anyway.
my structure
ROOT.zip
ROOT-DIR
LIB\*.jar
META-INF\plugin.xml

but still same error message

regards

0

Dmitry Kashin wrote:

LIB or lib ?


Hi,
thank you for your kind cooperation.
i have used all in small letter...
i am believing something is wrong over plugin upload manager.
i sent two emails to plugin admin but no response yet...
probably "503 Service Unavailable" :D

regards,

0

Dmitry Kashin wrote:

LIB or lib ?


Hi,
thank you for your kind cooperation.
i have used all in small letter...
i am believing something is wrong over plugin upload manager.
i sent two emails to plugin admin but no response yet...
probably "503 Service Unavailable" :D

regards,

0

Dmitry Kashin wrote:

LIB or lib ?


Hi,
thank you for your kind cooperation.
i have used all in small letter...
i am believing something is wrong over plugin upload manager.
i sent two emails to plugin admin but no response yet...
probably "503 Service Unavailable" :D

regards,

0

Dmitry Kashin wrote:

LIB or lib ?


Hi,
thank you for your kind cooperation.
i have used all in small letter...
i am believing something is wrong over plugin upload manager.
i sent two emails to plugin admin but no response yet...
probably "503 Service Unavailable" :D

regards,

0

Dmitry Kashin wrote:

> LIB or lib ?


Hi,
thank you for your kind cooperation.
i have used all in small letter...
i am believing something is wrong over plugin upload manager.
i sent two emails to plugin admin but no response yet...
probably "503 Service Unavailable" :D

regards,

0

Please sign in to leave a comment.