Plug-In Template Error

I am trying to compile the template plug-in sample that is at
http://www.intellij.org/twiki/bin/view/Main/ProjectPluginTemplate but when I
go to compile it I get the following error:

Information: 1 error
Information: 0 warnings
F:\pvcs4idea\src\com\intellij\openapi\samples\SampleApplicationPlugin.java
Error: line (21) cannot access
com.intellij.openapi.components.ApplicationComponent
bad class file:
D:\Development\Java\IntelliJ\lib\openapi.jar(com/intellij/openapi/components
/ApplicationComponent.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct
subdirectory of the classpath.


Any ideas as to what this is?

Thank you
John


2 comments

Hi,

you should set your target JDK to 1.4.1. Compiling IDEA-plugins against lower
version JDKs is not possible.

Sascha

"John D" <N_O__SP_A_M_JohnD@DelWare.com> schrieb im Newsbeitrag news:b38n9b$mnq$1@is.intellij.net...

I am trying to compile the template plug-in sample that is at
http://www.intellij.org/twiki/bin/view/Main/ProjectPluginTemplate but when I
go to compile it I get the following error:

>

Information: 1 error
Information: 0 warnings
F:\pvcs4idea\src\com\intellij\openapi\samples\SampleApplicationPlugin.java
Error: line (21) cannot access
com.intellij.openapi.components.ApplicationComponent
bad class file:
D:\Development\Java\IntelliJ\lib\openapi.jar(com/intellij/openapi/components
/ApplicationComponent.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct
subdirectory of the classpath.

>
>

Any ideas as to what this is?

>

Thank you
John

>
>


0

Yup, that was it. Thank You

John

"Sascha Weinreuter" <sascha.weinreuter@cit.de> wrote in message
news:b38qo0$rn5$1@is.intellij.net...

Hi,

>

you should set your target JDK to 1.4.1. Compiling IDEA-plugins against

lower

version JDKs is not possible.

>

Sascha

>

"John D" <N_O__SP_A_M_JohnD@DelWare.com> schrieb im Newsbeitrag

news:b38n9b$mnq$1@is.intellij.net...

I am trying to compile the template plug-in sample that is at
http://www.intellij.org/twiki/bin/view/Main/ProjectPluginTemplate but

when I

go to compile it I get the following error:

>

Information: 1 error
Information: 0 warnings

>

F:\pvcs4idea\src\com\intellij\openapi\samples\SampleApplicationPlugin.java

Error: line (21) cannot access
com.intellij.openapi.components.ApplicationComponent
bad class file:

>

D:\Development\Java\IntelliJ\lib\openapi.jar(com/intellij/openapi/components

/ApplicationComponent.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the

correct

subdirectory of the classpath.

>
>

Any ideas as to what this is?

>

Thank you
John

>
>

>
>


0

Please sign in to leave a comment.