Clearcase plugin and non-clear case source files

Hello,

Thank you for providing the ClearCase plugin. I am using it and enjoying it.

Recently my company switched from CVS to ClearCase.

In my old CVS IntelliJ projects I had

3 separate source trees
Used the multiple output paths option
2 of the source trees were under source control (CVS), the other source tree
wasn't

When using the integrated CVS versioning, IntelliJ was smart enough to
realize that part of the project was under source control and part of it was
not. So for example, when adding a new file to the branch under source
control, its tab would be green. However, if I added a new file to the
branch not under source control, the tab would be the normal black. Also in
the CVS view, I would not see the branch that was not under source control.
This was excellent, allowed me to work the way I want to.

I have tried to set up a project the same way with the ClearCase plugin. Now
when I add a file to the branch not under source control, it is colored
green. When I do CTRL + K, I see the added file, so I select the option to
exclude it from check in. But then when I do the check in, I get an error
from the plug in saying

"Unable to determine view for "C:\path not under source control name here":
not a ClearCase object"

And then IntelliJ and or the plugin hangs.

Thank you,

Ted Hill


5 comments
Comment actions Permalink

Was the path that caused the error excluded in the check in?
If is does look at the console and see if you can see a plugin output with
that path. If it does you might want to file a bug with JetBrains. The
plugin should not have received the path in the first place if you excluded
it.
If not could you please send me a project testcase? I would be more than
happy to fix it for you.

Jacques
"Ted Hill" <thill@tomotherapy.com> wrote in message
news:ap1e57$vh$1@is.intellij.net...

Hello,

>

Thank you for providing the ClearCase plugin. I am using it and enjoying

it.
>

Recently my company switched from CVS to ClearCase.

>

In my old CVS IntelliJ projects I had

>

3 separate source trees
Used the multiple output paths option
2 of the source trees were under source control (CVS), the other source

tree

wasn't

>

When using the integrated CVS versioning, IntelliJ was smart enough to
realize that part of the project was under source control and part of it

was

not. So for example, when adding a new file to the branch under source
control, its tab would be green. However, if I added a new file to the
branch not under source control, the tab would be the normal black. Also

in

the CVS view, I would not see the branch that was not under source

control.

This was excellent, allowed me to work the way I want to.

>

I have tried to set up a project the same way with the ClearCase plugin.

Now

when I add a file to the branch not under source control, it is colored
green. When I do CTRL + K, I see the added file, so I select the option to
exclude it from check in. But then when I do the check in, I get an error
from the plug in saying

>

"Unable to determine view for "C:\path not under source control name

here":

not a ClearCase object"

>

And then IntelliJ and or the plugin hangs.

>

Thank you,

>

Ted Hill

>
>


0
Comment actions Permalink

Hi Jacques,

I am still having this problem and would try to get it resolved, i.e. having
mutiple source trees within a single IntelliJ project, and some of the trees
are under ClearCase version control and others are not.

Again, my problem is that the ClearCase Plugin, or IntelliJ, seems to think
that everything is under ClearCase control (this is not the case with CVS,
there IntelliJ 'knows' which source tree is not under source control). When
I add a new file to a package not under source control, the ClearCase Plugin
thinks that it is under source control.

Your earlier email asked "was the path excluded in the check in?"

I don't see anyway to configure some paths to be 'included' and others to be
'excluded'

Can you give me more detail about how to exclude a path from source control?

Thank you,

Ted Hill


"Jacques Morel" <jacmorel@yahoo.com> wrote in message
news:ap2st8$rk9$1@is.intellij.net...

Was the path that caused the error excluded in the check in?
If is does look at the console and see if you can see a plugin output with
that path. If it does you might want to file a bug with JetBrains. The
plugin should not have received the path in the first place if you

excluded

it.
If not could you please send me a project testcase? I would be more than
happy to fix it for you.

>

Jacques
"Ted Hill" <thill@tomotherapy.com> wrote in message
news:ap1e57$vh$1@is.intellij.net...

Hello,

>

Thank you for providing the ClearCase plugin. I am using it and enjoying

it.
>

Recently my company switched from CVS to ClearCase.

>

In my old CVS IntelliJ projects I had

>

3 separate source trees
Used the multiple output paths option
2 of the source trees were under source control (CVS), the other source

tree

wasn't

>

When using the integrated CVS versioning, IntelliJ was smart enough to
realize that part of the project was under source control and part of it

was

not. So for example, when adding a new file to the branch under source
control, its tab would be green. However, if I added a new file to the
branch not under source control, the tab would be the normal black. Also

in

the CVS view, I would not see the branch that was not under source

control.

This was excellent, allowed me to work the way I want to.

>

I have tried to set up a project the same way with the ClearCase plugin.

Now

when I add a file to the branch not under source control, it is colored
green. When I do CTRL + K, I see the added file, so I select the option

to

exclude it from check in. But then when I do the check in, I get an

error

from the plug in saying

>

"Unable to determine view for "C:\path not under source control name

here":

not a ClearCase object"

>

And then IntelliJ and or the plugin hangs.

>

Thank you,

>

Ted Hill

>
>

>
>


0
Comment actions Permalink

I think what I meant was: Did you put these paths in the Excluded path
section of your project.
However I can infer from your email that it would not help you since you
would still need to see these files in IDEA which the Excluded paths would
hide completely.
I suggest you file a request for this because right now everything that is
not excluded will be presented to the check in project. You need to be able
to Exclude some paths from the VCS control but not necessarily from the
LVCS. Do you need IDEA to keep history on these paths that are not under
clearcase? I would unless I can completely regenerate the content of these
paths.

Let me know what you think.

Jacques


"Ted Hill" <thill@tomotherapy.com> wrote in message
news:b20kn2$vbk$1@is.intellij.net...

Hi Jacques,

>

I am still having this problem and would try to get it resolved, i.e.

having

mutiple source trees within a single IntelliJ project, and some of the

trees

are under ClearCase version control and others are not.

>

Again, my problem is that the ClearCase Plugin, or IntelliJ, seems to

think

that everything is under ClearCase control (this is not the case with CVS,
there IntelliJ 'knows' which source tree is not under source control).

When

I add a new file to a package not under source control, the ClearCase

Plugin

thinks that it is under source control.

>

Your earlier email asked "was the path excluded in the check in?"

>

I don't see anyway to configure some paths to be 'included' and others to

be

'excluded'

>

Can you give me more detail about how to exclude a path from source

control?
>

Thank you,

>

Ted Hill

>
>

"Jacques Morel" <jacmorel@yahoo.com> wrote in message
news:ap2st8$rk9$1@is.intellij.net...

Was the path that caused the error excluded in the check in?
If is does look at the console and see if you can see a plugin output

with

that path. If it does you might want to file a bug with JetBrains. The
plugin should not have received the path in the first place if you

excluded

it.
If not could you please send me a project testcase? I would be more than
happy to fix it for you.

>

Jacques
"Ted Hill" <thill@tomotherapy.com> wrote in message
news:ap1e57$vh$1@is.intellij.net...

Hello,

>

Thank you for providing the ClearCase plugin. I am using it and

enjoying

it.
>

Recently my company switched from CVS to ClearCase.

>

In my old CVS IntelliJ projects I had

>

3 separate source trees
Used the multiple output paths option
2 of the source trees were under source control (CVS), the other

source

tree

wasn't

>

When using the integrated CVS versioning, IntelliJ was smart enough to
realize that part of the project was under source control and part of

it

was

not. So for example, when adding a new file to the branch under source
control, its tab would be green. However, if I added a new file to the
branch not under source control, the tab would be the normal black.

Also

in

the CVS view, I would not see the branch that was not under source

control.

This was excellent, allowed me to work the way I want to.

>

I have tried to set up a project the same way with the ClearCase

plugin.

Now

when I add a file to the branch not under source control, it is

colored

green. When I do CTRL + K, I see the added file, so I select the

option

to

exclude it from check in. But then when I do the check in, I get an

error

from the plug in saying

>

"Unable to determine view for "C:\path not under source control name

here":

not a ClearCase object"

>

And then IntelliJ and or the plugin hangs.

>

Thank you,

>

Ted Hill

>
>

>
>

>
>


0
Comment actions Permalink

I have tried to set up a project the same way with the ClearCase plugin.

Now

when I add a file to the branch not under source control, it is colored
green. When I do CTRL + K, I see the added file, so I select the option to
exclude it from check in. But then when I do the check in, I get an error
from the plug in saying

>

"Unable to determine view for "C:\path not under source control name

here":

not a ClearCase object"

>
More specifically for this I need more info to determine if it is a bug in
the plugin or in IDEA. Could you turn on all diagnostics as show at
http://www.intellij.org/twiki/bin/view/Main/ClearcasePluginManual#Troublesho
oting and send me the log file.

Thanks

Jacques


0
Comment actions Permalink

Hi Jacques,

Thanks for following up on this.

I submitted a request, ID 9769.

I'm not familiar with the API for plugins, so not sure if I'm requesting the
right thing or not.

Thanks,

Ted Hill


"Jacques Morel" <jacmorel@yahoo.com> wrote in message
news:b23snh$1kr$1@is.intellij.net...

I think what I meant was: Did you put these paths in the Excluded path
section of your project.
However I can infer from your email that it would not help you since you
would still need to see these files in IDEA which the Excluded paths would
hide completely.
I suggest you file a request for this because right now everything that is
not excluded will be presented to the check in project. You need to be

able

to Exclude some paths from the VCS control but not necessarily from the
LVCS. Do you need IDEA to keep history on these paths that are not under
clearcase? I would unless I can completely regenerate the content of these
paths.

>

Let me know what you think.

>

Jacques

>
>

"Ted Hill" <thill@tomotherapy.com> wrote in message
news:b20kn2$vbk$1@is.intellij.net...

Hi Jacques,

>

I am still having this problem and would try to get it resolved, i.e.

having

mutiple source trees within a single IntelliJ project, and some of the

trees

are under ClearCase version control and others are not.

>

Again, my problem is that the ClearCase Plugin, or IntelliJ, seems to

think

that everything is under ClearCase control (this is not the case with

CVS,

there IntelliJ 'knows' which source tree is not under source control).

When

I add a new file to a package not under source control, the ClearCase

Plugin

thinks that it is under source control.

>

Your earlier email asked "was the path excluded in the check in?"

>

I don't see anyway to configure some paths to be 'included' and others

to

be

'excluded'

>

Can you give me more detail about how to exclude a path from source

control?
>

Thank you,

>

Ted Hill

>
>

"Jacques Morel" <jacmorel@yahoo.com> wrote in message
news:ap2st8$rk9$1@is.intellij.net...

Was the path that caused the error excluded in the check in?
If is does look at the console and see if you can see a plugin output

with

that path. If it does you might want to file a bug with JetBrains. The
plugin should not have received the path in the first place if you

excluded

it.
If not could you please send me a project testcase? I would be more

than

happy to fix it for you.

>

Jacques
"Ted Hill" <thill@tomotherapy.com> wrote in message
news:ap1e57$vh$1@is.intellij.net...

Hello,

>

Thank you for providing the ClearCase plugin. I am using it and

enjoying

it.
>

Recently my company switched from CVS to ClearCase.

>

In my old CVS IntelliJ projects I had

>

3 separate source trees
Used the multiple output paths option
2 of the source trees were under source control (CVS), the other

source

tree

wasn't

>

When using the integrated CVS versioning, IntelliJ was smart enough

to

realize that part of the project was under source control and part

of

it

was

not. So for example, when adding a new file to the branch under

source

control, its tab would be green. However, if I added a new file to

the

branch not under source control, the tab would be the normal black.

Also

in

the CVS view, I would not see the branch that was not under source

control.

This was excellent, allowed me to work the way I want to.

>

I have tried to set up a project the same way with the ClearCase

plugin.

Now

when I add a file to the branch not under source control, it is

colored

green. When I do CTRL + K, I see the added file, so I select the

option

to

exclude it from check in. But then when I do the check in, I get an

error

from the plug in saying

>

"Unable to determine view for "C:\path not under source control name

here":

not a ClearCase object"

>

And then IntelliJ and or the plugin hangs.

>

Thank you,

>

Ted Hill

>
>

>
>

>
>

>
>


0

Please sign in to leave a comment.