IDEA 5.0 vs 6.0 language plugins development question.


Hello.

How are you language plugin developers doing the maintenance of plugin
code with the changes in the language API between 5.0 and 6.0 versions of
IDEA ?

I have a custom language plugin and i want to use the same codebase mostly
for both IDEA 5.0 (for production users) and 6.0 (for myself and othere daring
souls) but i find it difficult to organize my code apart from having code
compilable only with IDEA 5.0 compatible devkits and code compilable only
with IDEA 6.0 compatible devkits. This usually means build.xml trickery and
different projects for IDEA 5.0 and IDEA 6.0 ... which i'm trying to avoid.

Thanks,
Mihai

PS,
I hope I made myself understood :-).


2 comments
Comment actions Permalink

I don't plan to support 6.0 until I stop supporting 5.0, because the
changes are too disruptive. At that point I'll probably branch to allow
for bugfixes in 5.0.

Toader Mihai Mihai-Claudiu wrote:


Hello.

How are you language plugin developers doing the maintenance of plugin
code with the changes in the language API between 5.0 and 6.0 versions
of IDEA ?

I have a custom language plugin and i want to use the same codebase
mostly for both IDEA 5.0 (for production users) and 6.0 (for myself and
othere daring souls) but i find it difficult to organize my code apart
from having code compilable only with IDEA 5.0 compatible devkits and
code compilable only with IDEA 6.0 compatible devkits. This usually
means build.xml trickery and different projects for IDEA 5.0 and IDEA
6.0 ... which i'm trying to avoid.

Thanks, Mihai

PS, I hope I made myself understood :-).

0
Comment actions Permalink

Separate code bases, and liberal use of BeyondCompare.

--Dave Griffith

0

Please sign in to leave a comment.