newbie help - can't compile

I'm attempting my first plug-in, but I can't even get it compiling. I've included lib\openapi.jar in the classpath, but keep getting this error. Using build 676. Anyone come across this before?

Information: 1 error
Information: 0 warnings
C:\dev\junk\openapi\TestAction.java
Error: line (10) cannot access com.intellij.openapi.actionSystem.AnAction
bad class file: C:\IntelliJ-IDEA-3.0\lib\openapi.jar(com/intellij/openapi/actionSystem/AnAction.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

1 comment
Comment actions Permalink

so sorry -- just found the other msg board which is more appropriate for this question.

0

Please sign in to leave a comment.