9 comments
Comment actions Permalink

Hendrik Schreiber wrote:

Hi,

=> http://www.tagtraum.com/ideajad.html

Installation instructions are in the readme.

Enjoy,

-hendrik

IdeaJad 666.1
=============
- Adjusted to changes in openapi
- Added decompile menu entries
- Added automatic decompilation when opening class
files


Excellent work Hendrik.
It is now up-to-par with the plugin I loved for JBuilder.

As a hint for usage, I create a sourceroot explicitly to receive
decompiled files and excude them from compilation.

Bug in this version: the 'decompile' menuitem on the classpath tree is
availbae also when multiple classes are seected (that's good) but only
decompiles the first selected file, so it doesn't honor the multiple
selection

Feature request for next version:
decompile a full package

cheers,
Edo

0
Comment actions Permalink

Great plugin!

Thanks Hendrik!

"Hendrik Schreiber" <hs@tagtraum.com> wrote in message
news:1071924.1035862708906.JavaMail.jrun@is.intellij.net...

Hi,

>

=> http://www.tagtraum.com/ideajad.html

>

Installation instructions are in the readme.

>

Enjoy,

>

-hendrik

>

IdeaJad 666.1
=============
- Adjusted to changes in openapi
- Added decompile menu entries
- Added automatic decompilation when opening class
files

>


0
Comment actions Permalink

You should not have to exclude something in the source path from compile.

By the way, one more request: ability to turn off the plugin for a particular
project.

Thanks, this is superb!

Edoardo Comar wrote:

Hendrik Schreiber wrote:

>> Hi,
>>
>> => http://www.tagtraum.com/ideajad.html
>>
>> Installation instructions are in the readme.
>>
>> Enjoy,
>>
>> -hendrik
>>
>> IdeaJad 666.1
>> =============
>> - Adjusted to changes in openapi
>> - Added decompile menu entries
>> - Added automatic decompilation when opening class
>> files
>>


Excellent work Hendrik.
It is now up-to-par with the plugin I loved for JBuilder.

As a hint for usage, I create a sourceroot explicitly to receive
decompiled files and excude them from compilation.

Bug in this version: the 'decompile' menuitem on the classpath tree is
availbae also when multiple classes are seected (that's good) but only
decompiles the first selected file, so it doesn't honor the multiple
selection

Feature request for next version:
decompile a full package

cheers,
Edo



--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0
Comment actions Permalink

Erb wrote:

You should not have to exclude something in the source path from compile.


why not ?
I usually don't want to try to (re)compile decompiled files. I only want
to browse them!

So having one sourceroot explicitly set aside for jad and excluded from
compileation workes great for me.

Edo

0
Comment actions Permalink

Hello Hendrik

The checkbox "Print default initializers for fields" overlaps with the "Use tabs instead of spaces..." checkbox on the plugin configuration pane.

0
Comment actions Permalink

I mean, the source path does not get compiled. Only if it is also
in the project path.

Edoardo Comar wrote:

Erb wrote:

>> You should not have to exclude something in the source path from compile.


why not ?
I usually don't want to try to (re)compile decompiled files. I only want
to browse them!

So having one sourceroot explicitly set aside for jad and excluded from
compileation workes great for me.

Edo



--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0
Comment actions Permalink

That's weird, which platform are you using?
Have you tried resizing your window. Does that help?
Can you please post a screenshot?

thanks!

-hendrik

0
Comment actions Permalink

Platform: WinNT SP6 + JDK 1.4.1
Resizing does not help.
How to reproduce:
1. Click on the "Use tabs..." checkbox.
2. Press Shift+Tab. Press Space.



Attachment(s):
jad.bmp
0
Comment actions Permalink

Hi Sergei - the issue is fixed in the new release.

thanks,

-hendrik

0

Please sign in to leave a comment.