log4j plugin with build 650

hey there,

I was trying to use the log4j plugin with build 650 and it spat out this
error message:

java.lang.NoSuchMethodError:
com.intellij.openapi.actionSystem.ActionManager.createActionToolBar(Ljava/la
ng/String;Lcom/intellij/openapi/actionSystem/ActionGrou
p;Z)Lcom/intellij/openapi/actionSystem/ActionToolBar;
at
com.webspherious.intellij.log4jmonitor.Log4JPlugin.initToolWindow(Log4JPlugi
n.java:80)
at
com.webspherious.intellij.log4jmonitor.Log4JPlugin.projectOpened(Log4JPlugin
.java:35)
at com.intellij.openapi.project.b.c.q(c.java:249)
at com.intellij.openapi.project.b.c.b(c.java:30)
at com.intellij.openapi.project.b.h.projectOpened(h.java:3)
at com.intellij.openapi.project.b.i.projectOpened(i.java:22)
at com.intellij.openapi.project.b.o.d(o.java:22)
at com.intellij.openapi.project.b.o.a(o.java:45)
at com.intellij.ide.a.q.a(q.java:6)
at com.intellij.idea.o.s(o.java:31)
at com.intellij.idea.o.c(o.java:14)
at com.intellij.idea.g.run(g.java:6)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at com.intellij.ide.p.a(p.java:61)
at com.intellij.ide.p.dispatchEvent(p.java:62)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:191)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:144)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:134)
at java.awt.Dialog.show(Dialog.java:524)
at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:822)
at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:624)
at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:595)
at com.intellij.diagnostic.d.run(d.java:1)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at com.intellij.ide.p.a(p.java:61)
at com.intellij.ide.p.dispatchEvent(p.java:62)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:191)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:144)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)

is it a case of me using the wrong version (I'm pretty sure I grabed the
latest one), or that I've got some configureation wrong?

Thanks,
Barranger



1 comment
Comment actions Permalink

createActionToolBar was remaned into createActionToolbar (please pay attention to case)

Best regards,
Vladimir Kondratyev
_____________________
JetBrains

Barranger Ridler wrote:

hey there,

I was trying to use the log4j plugin with build 650 and it spat out this
error message:

java.lang.NoSuchMethodError:
com.intellij.openapi.actionSystem.ActionManager.createActionToolBar(Ljava/la
ng/String;Lcom/intellij/openapi/actionSystem/ActionGrou
p;Z)Lcom/intellij/openapi/actionSystem/ActionToolBar;
at
com.webspherious.intellij.log4jmonitor.Log4JPlugin.initToolWindow(Log4JPlugi
n.java:80)
at
com.webspherious.intellij.log4jmonitor.Log4JPlugin.projectOpened(Log4JPlugin
.java:35)
at com.intellij.openapi.project.b.c.q(c.java:249)
at com.intellij.openapi.project.b.c.b(c.java:30)
at com.intellij.openapi.project.b.h.projectOpened(h.java:3)
at com.intellij.openapi.project.b.i.projectOpened(i.java:22)
at com.intellij.openapi.project.b.o.d(o.java:22)
at com.intellij.openapi.project.b.o.a(o.java:45)
at com.intellij.ide.a.q.a(q.java:6)
at com.intellij.idea.o.s(o.java:31)
at com.intellij.idea.o.c(o.java:14)
at com.intellij.idea.g.run(g.java:6)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at com.intellij.ide.p.a(p.java:61)
at com.intellij.ide.p.dispatchEvent(p.java:62)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:191)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:144)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:134)
at java.awt.Dialog.show(Dialog.java:524)
at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:822)
at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:624)
at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:595)
at com.intellij.diagnostic.d.run(d.java:1)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
at com.intellij.ide.p.a(p.java:61)
at com.intellij.ide.p.dispatchEvent(p.java:62)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:191)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:144)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)

is it a case of me using the wrong version (I'm pretty sure I grabed the
latest one), or that I've got some configureation wrong?

Thanks,
Barranger


0

Please sign in to leave a comment.