Classfile has wrong version 48.0 ??? Help ...

Hi Everybody,

I am new to OpenAPI and it seems that the start only is not that easy. When I write a plugin and try to compile it - I get the following error -
-





-



Can anybody help - any help will be greatly appreciated.

Thanks in advance

- Ashish

3 comments

This is just a guess, but it sounds like you are using incompatible JDK's. I think you are trying to compile with an older JDK against newer .class files which are version 48.0. In other words, IntelliJ compiled the .class files in openapi.jar with a newer version of Java (probably 1.4.1 or 1.4.2) than you are using.

Check "java -version" and if it indicates a version older than 1.4.1 or 1.4.2, try upgrading.

-Dave

0

Hi Dave,

Thanks a lot. I installed jdk 1.4.1 and now the classes are compiling just fine.

Thanks once again

Regards
- Ashish

0

Hi Dave,

Thanks a lot. I installed the "jdk 1.4.1" and the classes are compiling just fine.

Regards
- Ashish

0

Please sign in to leave a comment.