openapi versioning problem

On a couple of our machines here I am getting a compile error with the openapi.jar file that I'm using. On my machine however everything is fine.

The error says that there is some problem between version 47 and 48. It seems bizare though b/c the same jar file appears to work fine on one box and not another.

Has anyone else seen anything like this?

~harris

1 comment
Comment actions Permalink

the openide.jar is compiled with jdk1.4 in class version 48 format

you'll get this error if you try to compile against the jar with jdk1.3 (which expects classes in version 47 or lower)

more info:

http://www.javaworld.com/javaqa/2003-05/02-qa-0523-version_p.html






0

Please sign in to leave a comment.