Alt + Enter no longer works on OS X (yosemite)

The last update seems to have broken this keyboard shortcut somehow for me. I get the popup, but
nothing happens on hitting Alt + Enter

I have gone back to IDEA 14 which still works fine. Anyone else experiencing this?

14 comments
Comment actions Permalink

Unfortunately there is nothing in the logs

I have tried disabling ALL plugins except Scala, still doesn't work

The link provided is for IDEA 14, which I also have installed and works fine. The issue happens only with 15 EAP

0
Comment actions Permalink

Attach idea.log from IDEA 15.

0
Comment actions Permalink

Hi Serge

I have re-enabled a bunch of plugins. I shut down my idea, deleted all the logs and did a fresh start.

Then deleted an import statement from a class, waited for the Alt + Enter popup to appear asking me to import the class. Hit Alt+Enter several times without any effect and finally closed IDEA

I have attached the resulting logfile



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Try again with the following plugins disabled:

.ignore (1.2), BashSupport (1.5.1.143), NodeJS (143.110), Presentation Assistant (0.9.6), Python (5.0.142.2), Quick Notes (2.9.4), Scala (1.9.2)  

0
Comment actions Permalink

Still no luck

Attached new logfile



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Did you change the keymap? What keymap do you use now?

Try to remove IDE config folder to start with the defaults: https://intellij-support.jetbrains.com/entries/23358108 .

0
Comment actions Permalink

Hi

I'm using standard 10.5+ mappings

I just wiped the config folder under ~/Library/Preferences/IntelliJIdea15, started IDEA. Went through the setup process and left all the default plugins enabled

I then opened a Java project and tried it out. Still not working :(

0
Comment actions Permalink

Try the next EAP what it's available. Something may be broken in this build, but I don't recall similar reports.

0
Comment actions Permalink

I'll check out the next build and report. However without actually using EAP 15 I may not notice when the next build goes out. I'd appreciate, if you remember, if you could post in this thread so I get an email alert

I'll go back to 14 in the meantime

Thanks

0
Comment actions Permalink

Hello Serge

I have found what was causing it, but it somehow doesn't affect IDEA 14, whereas it affects IDEA 15

I have added the "Unicode Hex Input" as one of my keyboard mappings to type some special characters every now and again. If I have this keyboard enabled, the Alt + Enter does not register in IDEA 15, but registers perfectly under IDEA 14.

I have just tried on a separate Mac, and I see the same problem. If the "Unicode Hex Input" keyboard mapping is selected, the Alt+Enter shortcut doesn't work in IDEA 15 but it does in IDEA 14

Cheers

0
Comment actions Permalink

What you're looking for is the "Intention Actions" which for some reason shows up as Alt+Enter on OSX despite the fact that it's default mapping is ⌥⏎.

If you want to remap this functionality, go to the Keymap and search for "Show Intention Actions" and change the mapping. Have a look here for more details.

Edit:

I reported this as: https://youtrack.jetbrains.com/issue/IDEA-174618

0
Comment actions Permalink

Try the right alt key on an iMac.

0
Comment actions Permalink

Just solved it for my machine: I had a system-wide shortcut on alt-enter.

Use the Apple menu -> system preferences -> Keyboard -> Shortcuts

In the left container select "Keyboard"

At my machine I had an activated shortcut "Move focus to the window toolbar"   which was alt-enter.

Disabled it and it works again in IntelliJ

 

(To find out if something else is eating alt-enter try reassigning it to something else in IntelliJ's keyboard settings - if it does not register there, some other tool is swallowing the sequence. System preferences in my case, but it might also be any other running tool.)

 

0

Please sign in to leave a comment.