In 4675.3 Scala worksheets appear to have stopped working

I upgraded from latest release version to the latest EAP (also took the EAP Scala plugin) and my Scala worksheets have stopped working.

Project build is still fine, and running code as an App behaves ok.  However, code in worksheets cannot evaluate - the worksheets all show the message 'No Scala SDK configured for module: <module name>'.

In Project structure the SDK appears where I would expect it to (as per image below), and since it seems to work ok for building and running app code I assume the issue ios worksheet-specific.

The exact versions I am using are 142.4675.3 of IntelliJ, and 1.8.196.1 of the Scala plugin

dependencies.jpg
Has anyone else seen this, and does anyone know how to work around it? (for now I'll return to a release build, but apart from that)

1 comment
Comment actions Permalink

During SBT import Scala SDK library will be created. Try to reimport project, or even delete .idea directory and import project again.
On screenshot you can see how "Scala SDK" library looks like (third line).
Screen Shot 2015-09-17 at 18.35.58.png

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.