cpu sweating

Hi all,

Since the latest update I received, which made my IntelliJ go from 9.0.3 to 9.0.4, my cpu has to work really hard after some point during a session of IntelliJ.
I'm totally not sure whether this has anything to do with the upgrade, but rather with java.

`top` on my machine at such a point says:

11089- JavaApplicat 159.1 22:52.64 71/1 1    706  949   757M   51M    754M   844M   2077M  11089 1616  running  501  1325839+  14779   5010817+

where the 159.1 is the %CPU column. The fan is running like crazy. Usually it only helps to quit IntelliJ.

Another annoying thing which I'm saying here because it might be related (not asking 2 questions), which occurs since I upgraded Java to 1.6.0_22 is that my project seems not to know which JDK I'm using.
Running a debugger results in a pop up: "Cannot find home directory '/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home' for JDK '1.6'. Update JDK configuration"
I have to specify a JDK (Module Settings | SDKs | JSDK home path) each time I start IntelliJ again.

My environment
Mac Snow Leopard
IntelliJ IDEA 9.0.4, Build #IU-95.627

java -version says:
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)

Any help would be greatly appreciated,
Paul

3 comments
Comment actions Permalink

What about the second question? I get this error everytime I make a project/module after IntelliJ has started:

Cannot find home directory '/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home' for JDK '1.6'.
Update JDK configuration.



I then have to fix this by:
  1. Open Module Settings
  2. Choose Platform Settings / SDKs
  3. Click the Select Path (...) button and choose the directory already listed in the field "JSDK home path"
  4. Click OK
  5. Build project module
0
Comment actions Permalink

My apologies for exhuming an old thread, but I am having this exact same problem.  IntelliJ also loses the setting in the SourcePath tab, so I have to keep re-finding the source.jar file for it also.  This is the case no matter what project I open.  This started happening about two months ago; prior to that, IntelliJ was a happy camper.

I have repaired permissions and repaired the disk; no improvement.

I  have also tried moving IntelliJ's folder out of my ~/Library/Preferences  and letting it construct an entirely new one; no improvement.


Did you ever fix the problem, Kloper?  Do you remember what you did?  Has anyone else had this problem and knows how to fix it?



FYI, I am on IntelliJ 9.0.2, Build #IC-95.66
Mac running 10.6.8

(Yes, I know they are both very old; please don't waste my time or yours by advising me to upgrade.  My hope is that someone who had this problem years ago remembers what they did to solve it.)

java -version output:
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-10M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)


Was this a known issue in IntelliJ 9.x (in which case I will just have to put up with it)?


Many TIA, this is driving me nuts!

0

Please sign in to leave a comment.