Can't paste text from anywhere other than IntelliJ (10.5)

I can copy/paste text within the IntelliJ editor window without any problems.  But I cannot copy text from any other application and paste into IntelliJ's editor window.  I just get a beep sound as if it's an error.

I am using 10.5.1 evaluation version.  This problem also occurs in 10.5 Community version and on other developers machines (we are all using Win XP). I haven't had an upgrade since 7.0.4 so I don't know if this problem appeared in an earlier version.  I searched the discussions and didn't find a similar issue.

Any ideas as to what is wrong or what I need to do paste from other apps?

7 comments
Comment actions Permalink

Are there any errors in idea.log file (use Help | 'Reveal Log' action to open directory containing the log file)?

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I don't see any error related to this.  Attached is the log.  The only thing I have done today (7/6/2011) is check a file out of Perforce and try to paste into it from Wordpad.  If you check the log for 7/6, you will see the Perforce check out but nothing else.

BTW - thanks for telling me how to get to the idea.log directory.  That was very helpful.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Some more information:

We have 3 developers using 10.5 - 2 on Community, 1 on eval (me).  We are all on Win XP

One of the Community users can paste without issue.  She used to be on 7.0.4 and converted her settings to 10.5 when loading her project.  She said she didn't change any settings.

The other Community user was not using IntelliJ before.  He couldn't paste.  He played with encoding settings and swears he only did the following and is now able to paste:

File->"Reload windows-1252..." -> Configure Default Encoding.  Change properties from System Default to UTF-8

I am on the evaluation version.  I used to be on 7.0.4 and simply converted my settings to 10.5 when loading my project (just like the first user).  I installed more features than I had in 7.0.4 when I did the install.  I also played with the fonts alot but don't recall changing any other settings.  I can't paste from an external app.  I even tried to change the encoding like my co-worker but I still can't do it.

I'm hoping this information helps you identify what is wrong.  Not being able to paste from other apps is causing a lot of problems for me.  I want to use the purchased version for all of the other features but if I can only paste via the free version, I may have to go with that.  Or stay on version 7 :(

1.   

0
Comment actions Permalink

Is 'Use soft wraps in editor' option enabled in Settings | Editor ?
Could you please try to paste from an external app into a simple text field (e.g. into 'Name' field in 'Create New Class' dialog)?

Some more information:

>

We have 3 developers using 10.5 - 2 on Community, 1 on eval (me).  We are all on Win XP

>

One of the Community users can paste without issue.  She used to be on 7.0.4 and converted her settings to 10.5 when loading her project.  She said she didn't change any settings.

>

The other Community user was not using IntelliJ before.  He couldn't paste.  He played with encoding settings and swears he only did the following and is now able to paste:

>

File->"Reload windows-1252..." ->  Configure Default Encoding.  Change properties from System Default to UTF-8

>

I am on the evaluation version.  I used to be on 7.0.4 and simply converted my settings to 10.5 when loading my project (just like the first user).  I installed more features than I had in 7.0.4 when I did the install.  I also played with the fonts alot but don't recall changing any other settings.  I can't paste from an external app.  I even tried to change the encoding like my co-worker but I still can't do it.

>

I'm hoping this information helps you identify what is wrong.  Not being able to paste from other apps is causing a lot of problems for me.  I want to use the purchased version for all of the other features but if I can only paste via the free version, I may have to go with that.  Or stay on version 7 :(

>

1.

>

---
Original message URL: http://devnet.jetbrains.net/message/5308819#5308819



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I have been working with Serge in tech support for the past few days and we were finally able to figure out what was wrong.  Before I explain, I want to satisfy your curiousity - I tried with and without soft wraps and could not paste.

The pasting problem is due to a conflict with Prevx (anti-virus software).  I had safe online browsing turned on in Prevx.  If I brought up sites like Gmail or my web-based Outlook, Prevx was securing them and blocking the clipboard.  The odd part is that this does not cause a problem with any other application, including IntelliJ 7.  I'm wondering if Prevx did something to IntelliJ 10.5 upon installation that is causing the problem (I did not turn off Prevx monitoring when I installed IntelliJ).

I am working with Prevx support to solve the problem.  In the meantime, I can turn off the monitoring when pasting.

0
Comment actions Permalink

Prevx has fixed the problem.  They made changes to their database so there is no need to get a new version.

0
Comment actions Permalink

it will happen when copyed text from Terminal . for this ,you can copy from editor once .ok,it works !

i am using 15. I am hoping to help you

0

Please sign in to leave a comment.