ruby plugin

So I'm using intellij ultimate and I've added the Ruby plugin. However all I seem to get is syntax highlighting, all other language features appear to be missing. For example basic functions/keywords like 'puts' and 'require' are highlighted as errors with the message "Cannot find 'puts/require'". I've installed the Python and PHP plugins and did not have any issues. I also noticed that the Ruby language options in preferences seem to be limited, I don't have any option to specifiy the interpreter or anything like I do with PHP/Python. Ruby does not have an entry underneath "Languages & Frameworks" the way the other languages do.

I tried googling but I can't seem to find this issue elsewhere, I keep finding results for rubymine but of course rubymine standalone works fine.


In short the Ruby plugin seems to be only giving me syntax highlighting but absolutely nothing else (no autocompletion or even recognition of standard library methods or keywords). I've tried un-installing and re-installing the plugin but that didn't work.

Hopefully I'm just doing something wrong, I'm working with a codebase that only has a handful of ruby scripts so I'd prefer to not have to use standalone rubymine.


I am using Intellij Ultimate Edition 15.0.1, the plugin is the official Ruby jetbrains plugin version 8.0.0.20151112

1 comment
Comment actions Permalink

Hi Andrew,

in order to get ruby code insight you need either to create Ruby module for your Ruby sources or add JRuby facet in your module settings. Sdk can be specified in module/facet settings depending on the way you choose

0

Please sign in to leave a comment.