14.1 EAP - incompatible Python and Ruby plugins

14.1 EAP flags the Python and Ruby plugins as being incompatible on startup. Can we get new versions pushed for this?

Thansk!

6 comments
Comment actions Permalink

+1 for the Python plugin.

Scala plugin too had issued, but I saw that they had relesed an EAP build with an older version number (1.2.x vs 1.3), so if you uninstall the existing plugin, you can then install the EAP plugin.

0
Comment actions Permalink

The quick fix is to modify python.jar/META-INF/plugin.xml in the plugin folder.

<idea-version since-build="139.1117" until-build="139.*"/>
to
<idea-version since-build="139.1117" until-build="140.*"/>

0
Comment actions Permalink

FYI - for anyone that hit this and backed off the EAP, new plugins are out.

0
Comment actions Permalink

Thanks for that info Chris, those incompatibilities did make me hold off on the EAP, not just for those specific plugins, but out of concern that others might have similar problems. Do we have a sense how widespread this sort of issue is?

Do those new plugin versions you mentioned mean that the current EAP will automatically know they can be updated now, or are manual steps required?

0
Comment actions Permalink

The plugins should auto-update when you launch IDEA, assuming you have update checks turned on. If not, just go into the plugin manager and search for updates.

I've had no issues with other plugins at this point.

0
Comment actions Permalink

OK, thanks, that's what I was expecting, just making sure that normal mechanism covers this situation in the EAP.

Maybe it's time to jump in then, if there are no other major blockers. Maybe. Can't really afford the time for IDEA to go sidewise on me...

0

Please sign in to leave a comment.