How to recognize ruby new hash syntax

I have only ruby 2.1.1 installed (on OSX) and the language level shown by IDEA is 2.1. Yet the new hash sytnax is shows as an error. Is this a bug or is there some other settings that I missing?

Please sign in to leave a comment.