.ideaLibSources and .idea-build directories under %USERPROFILE%

Hi guys,
I am using IntelliJ IDEA 15.0.1 with Scala plugin in my corporate Windows 7 Enterprise laptop with the following overridden settings in idea.properties:

idea.config.path=/Tools/idea-settings/config
idea.system.path=/Tools/idea-settings/system

Thanks to these settings, all the IntelliJ settings go into C:\Tools\idea-settings directory, so I have managed to store more than 800MB of data in another directory than my %USERPROFILE% dir.

Issue 1: But still, when I click download sources for some jars it is being downloaded into %USERPROFILE%\.ideaLibSources directory which I do not want at all.

Issue 2: Also when first time IntelliJ compiles a scala project it creates %USERPROFILE%\.idea-build\scala-compiler-interfaces directory with compiler-interface jar files for each scala version I have.

How can I override these "sources download" and "idea build" directories?

5 comments
Comment actions Permalink

It appears to be a bug and I've informed the responsible developers about it, should be fixed in the future updates.

Right now you can try adding -Duser.home=/path/to/some/other/folder into .vmoptions (https://intellij-support.jetbrains.com/entries/23395793) and into Scala compiler process arguments.

0
Comment actions Permalink

You can customize location of .ideaLibSources in the idea.properties file, using "idea.library.source.dir" key. But path to .idea-build is hardcoded relative to "user.home" directory now. I'll fix it by the next scala-plugin release.

0
Comment actions Permalink

Thanks guys, defining user.home solved my first issue for now, and I'll wait for the fix for the second issue. Thanks again for responding so quickly.

0
Comment actions Permalink

Is possibility of change location for .idea-build already fixed?

Changing -Duser.home don't work for me because what I notice it breaks other plugins settings.

0
Comment actions Permalink

Yes, you may define custom path with the following property:

-Dscala.compiler.interfaces.dir
0

Please sign in to leave a comment.