Terminal in IDEA: How to make it NOT login terminal

I am on Kubuntu and my login shell is zsh.

However when I open a terminal toolwindow in IDEA, the terminal in there is always a login terminal.
Why is that so? Can I make it a non-login shell?

In the "Tools -> Terminal" settings panel there is no option to do so and the "Shell path" input just reads "/usr/bin/zsh"
I only know that you can pass "-l" (or just - ") to make a new zsh a login shell.

But I haven't found an option to explicitly make it a non-login shell.

1 comment
Comment actions Permalink

Looks like currently login shell is always used. Here's a related ticket - https://youtrack.jetbrains.com/issue/IDEA-114126.

0

Please sign in to leave a comment.