Running IDEA with JDK 1.8 on OSX

Basically: http://youtrack.jetbrains.com/issue/IDEA-123552

If I try to set IDEA_JDK, IDEA won't start.  I get "com.apple.launchd.peruser.635759893[297]: (com.jetbrains.intellij.67616[2210]) Exited with code: 1" in the console log.

I have to edit JVMVersion in /Applications/IntelliJ\ IDEA\ 13.app/Contents/Info.plist to make IDEA run with JDK 1.8 (or 1.7).

Does anyone know how to run IDEA on a newer JDK without editing Info.plist on OSX?

I'm trying this with the latest EAP, but I have a feeling the behaviour is the same in 13.x.

3 comments

I would be surprised if it were possible, without editting the Info.plist .

That is what I have been doing ever since Mavericks with the Apple 1.6 JVM being optional, I don't have that installed.

It is little trouble for EAP upgrade.  The man gotcha is: when installing from an entirely new .dmg, rather than a patch, run the Application once and refuse the option of installing the Apple 1.6 JVM, then edit the Info.plist and run IDEA again.  Otherwise Mavericks complains that the Application is corrupted.

Perhaps someone else know better, I don't know.

ATB

0

I tried to use both JVM 7 & 8 w/ IntelliJ. The result is that the Mac freezes in both cases after some hours running IntelliJ w/ JVM 7/8. Of course I can't exactly proof that this is the reason but I tried it several times. Usually I have an uptime of > 30d. Running IntelliJ w/ JVM 7/8 reduced the uptime *every time* to < 2d.

Clearly it's a Mac OS X issue and a nasty one. But we have to find out a solution how to track down the problem as JVM 6 is not supported by Oracle anymore since over a year. A workaround could be found on the JVM or on IntelliJ level. Of course a solution from Apple would be appreciated even more.

Are you guys from JetBrains working on this issue?

0

For what it is worth, I've not really had such a problem.  I have been running the EAPs under 1.7 pretty much since the Info.plist setting was first noted here.  Like everyone, I expect, using 1.7 or not, I have had occasonal problems.

In general & certainly at the moment I don't think I see failures after less than two days, I would guess I most typically run for a couple of weeks without problem.

Of course, I may noy be using the EAP with a different mix of feature use, not to mention plugins.  In my case I work mainly in Java with Play framework 1 & Scala with Play framework 2.

Of course, I do hope that the problem you see gets fixed.

Just another point of reference

0

Please sign in to leave a comment.