Turning off Auto code unfolding

I'm sure this was a total oversight in development, but how do you turn off the insane code unfolding?

For no reason at all, my nicely folded code, will unfold, without me asking it to.  I looked in the menu, but couldn't find a setting that was causing this, it has to be somewhere, this is an annoying enough bug, to make me want to go back to straight VIM.   I'm running 14.1.4.

Thanks
Docmur

1 comment
Comment actions Permalink

Yes, this happens quite a lot and makes working it unfeasable to collapse specific parts and continue to work in that file.

I think it is not intentionally, but a side effect of other actions.

A quick search in YouTrack yields:

IDEA-131718 Syntax errors make code foldings unfold
IDEA-80778 Folding - provide an option to NOT automatically unfold when user performs Find.
IDEA-123978 Code unfolds when adding a comment
IDEA-78128 Pasting blocks of XML into a folded document ruins folding
IDEA-121437 When navigating to a method with folded body, it's unfolded and folded back immediately
IDEA-120779 Editing XML file: do not unfold last folded item when not closed tag is inserted after it
IDEA-76730 Do not unfold folded block when it is moved with Tab
IDEA-84492 Multiline commenting (Ctrl + Shift + /) unfolds collapsed blocks of code
IDEA-68794 Do not unfold methods when moving them around

You could vote/comment on those issues.

My impression is that it is a conceptual problem and would have to be worked on in general.

1

Please sign in to leave a comment.