LiveEdit closes projects

RC1 (build 135.406) I installed the 0.4.124.1 current LiveEdit plugin; then, selecting any project to open causes the IDE to appear, with a flash of pink which I think is the "IDE error" dialog, but the IDE close back to the project/configuration launch screen immedaiely. I can create a new project, even an empty one, can't *open* that project (nor any pre-existing project). If I disable the LiveEdit plugin from the project/configuration launch screen then I'm back to normal. But there's no entry in the Event Log window for me to use to make an error report.

Windows 7 Home/64 bit

3 comments
Comment actions Permalink

Seems to be fixed in 135.445 - I can enable the LE plugin and create/open projects on Win 7, so the forced-close is gone. (The plugin is 'red' in the plugins list - there's no LiveEdit *functionality* - but the force-close is eliminated)

0
Comment actions Permalink

Well, I said 'solved' too soon :( just installed a brand new Fedora 20 (Linux) VM, updated it, then a brand new install of build
134.445, seems OK - installed LiveEdit, it force closes. Disable Live Edit, IDEA opens the projects.

0
Comment actions Permalink

I think I see what could be causing the force-close - as I said, I was installing the 0.4.124.1 version of the plugin, rather than the current (1.18.134.3.) version. That's an old and probably incompatible version.

Why is that getting loaded? Because the most recent version of the plugin has an "until-build" of 135.0, but the EAP is 135.445 ... so, the plugin loader looks back and finds this old 0.4 version, which has a blank "until-build" field (see http://plugins.jetbrains.com/plugin/7007).

I tried downloading and install-from-disk of the current version... I unjar'ed that and edited the plugin.xml to '<idea-version until-build="135.9999" since-build="134.1446"/>' and re-jar'ed but while that loaded, it didn't seem to provide a LiveEdit view, and so I gave up for now.

0

Please sign in to leave a comment.