IntelliJ 15: Flex code incorrect red errors

I have just installed IntelliJ v15 ready to test before rolling out to our developers. We use it to do Flex/AS development.

I am getting a bunch of false red errors. If I compile the propject it all works fine.

Problem 1 - "Protected member is not accessible":
Protected member is not accessible.png
The TimeSequenceValue method is simply a protected method in the Superclass (dunno why these uploaded images are coming up so small!):

TimeSequenceValue in Superclass.PNG

Problem 2 - "Attribute x not allowed here":

Random properties and event handlers come up as red errors in MXML markup when they are allowed.
Attributes not allowed here.png

The Superclass to this also gets some red:
Event handler not allowed here.png
gantt:ResourceChart is a third party component com.ibm.ilog.elixir.gantt.ResourceChart (IBM's ILog Elixir Gantt chart). I don't know if that has some bearing on the problem.


Problem 3 - "Element x not allowed here":

When using the third party component in the previous screenshot (com.ibm.ilog.elixir.gantt.ResourceChart) I get incorrect error when specifiying complex properties in MXML. Hovering gives "Element gantt:ganttSheet is not allowed here":
MXML Properties.PNG

Do I need to raise actual bugs against these problems?

Problem 1 and 2 are new to V15, not happening in V14.1.5. Problem 3 is also happening in V14.1.5.

Cheers, Darren

11 comments
Comment actions Permalink

1st problem looks like https://youtrack.jetbrains.com/issue/IDEA-147365 that will be fixed ASAP.

2nd one - not sure. May be the same if all red attributes should resolve to protected members as well. It'd be great if you can attach a sample project to check.

3rd one - YouTrack issue (Flash_Flex subsystem) is welcome, please attach sample project to reproduce.

0
Comment actions Permalink

As we are considering moving everyone to Windows 10 I thought getting everyone up to IntelliJ 15 in the process would be good. So got a chance to check if these have been fixed in 15.0.4.

Problem 1 has been fixed (hurrah).

Problem 2 and 3 are still present. I tried loading our prototype project up which uses the same components, hoping I'd be able to send you that as a sample project, but it doesn't occur in there.

Any ideas on how I we can progress with these? Do I need to set up a YouTrack?

 

0
Comment actions Permalink

Yes, as I wrote back in November, YouTrack issue (Flash_Flex subsystem) with sample project to reproduce is the right way to go. I'm afraid issue without a reproducible case would not be actionable.

0
Comment actions Permalink

Ok, I have a problem doing that though.

The classes experiencing the problem inherit from the com.ibm.ilog.elixir.gannt.ResourceChart which is a paid for third party component, so I wouldn't be able to include that in the project.

Also, I cannot get a smaller project exhibiting the problem. The real application is absolutely huge!

We are stuck on 13.1.3 until we can get this resolved as that component is fundamental to our product. It does it in v14 too.

0
Comment actions Permalink

Usually it is enough to write 2-3 sample files from scratch with some specific code that reproduces the issue. Obviously I can't help you doing it without access to the project, I can only advise to take a look at how those entities that are red in your code are declared. What is the class hierarchy and physical location of files that are related to the file with red code and file where those red entities are declared.

I may do a quick check of your project structure without looking at code - sometimes it reveals issues that cause red code. Do do it I need .idea folder and all *.iml files zipped. You can attach them here if they do not contain private information.

0
Comment actions Permalink

We have a small project to test our customisations of the gantt chart and it doesn't suffer from the false reds. If I get some time I'll try a totally new project from scratch.

Class hierarchy is:

com.ibm.ilog.elixir.gantt.GanttChartBase
com.ibm.ilog.elixir.gantt.ResourceChart (both from ilog-elixir-enterprise.swc)
DiaryResourceChart.mxml (C:\Workspaces\DevHealthRoster_10_5_2_NSW_Calypso\Products\HealthRoster\Deliverables\ClientUI\src\UI\Diary)
RosterResourceChart.mxml (C:\Workspaces\DevHealthRoster_10_5_2_NSW_Calypso\Products\HealthRoster\Deliverables\ClientUI\src\UI\RosterDemand\RosterDiary)

The swc is linked as a dependency in a module library:

I've created a zip of the project .idea folder and the iml files. Could I email it to you direct (what is your email)? Would prefer not to attach it to a public post.

0
Comment actions Permalink

Sure, alexander dot doroshko аt jetbrains dotcom.

0
Comment actions Permalink

Sent the project files (as you have probably already seen).

I tried a brand new project, creating a module library just containing ilog-elixir-enterprise.swc and ilog-elixir-enterprise_rb.swc.

Copied over DiaryResourceChart.mxml and RosterResourceChart.mxml creating its dependencies (dummy versions) and it all works fine, no red errors.

So it could be a project file problem or something more subtle. These project files have been through many versions of IntelliJ and originally created by a wizard from FlashBuilder project files, so there could well be a host of redundant rubbish in there!

0
Comment actions Permalink

There was some email exchange between myself and Alexander, which ultimately came down to we needed a small project that exhibited the problem.

I have now managed to whittle back our enterprise solution to a small project retaining the problem.

Alexander, are you still working for JB? I sent you the project last week (obviously after a big gap in time) but got no response. Would this be picked up by yourself or someone else?

0
Comment actions Permalink

Hi, I've just came back from vacation. Will answer shortly.

0

Please sign in to leave a comment.