new user - hi dpi. Fonts are all blurry

Hi,
I'm a .NET developer trying to get into Android and Java development.

I have successfully managed to setup a basic project in Intellij12 community edition however I use a hi dpi (3200 x 1800) and all the fonts are blurry and everything seems fuzzy.
Is there anything I can do to correct or adjust this?
Thank you for your time.

10 comments

I should add I using Windows 8.1 x64. Thank you.

0

Will Settings | Editor | Appearance | Use anti-aliased fonts help?
Please attach a screenshot.

1

Thank you for the reply.
I do have that option enabled, I have made the font a little bigger which makes things more workable. However just wondering if I could make things even crisper as it hurts my eyes after working for a while.



Attachment(s):
Capture.PNG
0

Hello Barry,
at the moment Apple Retina laptops are the only HiDPI devices we support. Could you please send us your hardware configuration? Also could you please visit https://java.net/projects/ojt-accessibility/downloads/directory/Demos , download swingset2.jar, and run it as java -jar swingset2.jar
Then go to teh Text section and try to read book contents. Is it blurry?

0

Thank you for the reply Konstantin,
Here are my specs;

Processor Intel Core i5-4200U
RAM capacity 4.00GB
Memory type DDR3
Screen and video
Screen size 13.3in
Resolution screen horizontal 3,200
Resolution screen vertical 1,600
Resolution 3200 x 1600
Graphics chipset Intel HD Graphics 4400


I have attached a screen shot of the demo you sent me.

At first it looks like it could be ok, however it's not upscaling and when I look closely it also looks like it could be blurry.
Thank you for help here, I really appreciate any information.



Attachment(s):
Capture.PNG
0

Thanks! Looks like we should buy one of these hidpi devices. We fully supported hidpi on retina devices (including icons and images), but notebooks like yours are not in the list. The problem here is that Java makes all images twice larger on hidpi devices. Our editor is a hand-made component and in fact it's an image. I've shared some details on the problem here http://bulenkov.com/2013/06/23/retina-support-in-oracle-jdk-1-7/ So, as soon as we get a device we will fix the problem.

0

Thanks again Konstantin!
Here is a link the the actual device I am using;
http://www.samsung.com/uk/consumer/pc-peripherals/notebook-computers/ultra-portable/NP940X3G-K01UK

I look forward to getting HiDPI running eventually on Windows, that would be an awesome fix!
Best Regards,
Barry

0

There's a lot more devices already on the market where this will be an issue. Ultrabooks with FHD or higher resolutions at 11" or 13" are prime candidates for these issues (FHD @ 13" requires 125% scaling to retain proper proportions, 3200x1800 even 200%). I have both the same Samsung device as the previous poster, and a UP3214Q, the latter running at 150%.
I think the solution to determine whether to activate HiDP support shouldn't depend on brand, but rather DPI settings (or perhaps the scaling can be determined and if it's > 100%, activate HiDP support - since HiDP on windows isn't all a linear doubling of the number of pixels in both directions but can be something in between). With the UP2413Q already out and an 28" in the pipeline, things really are picking up on the HiDP front.

1

OK So I've actually worked this one out.

1) Disable scaling in Intellij : Right click the icon when running, choose "Compatability" Choose "Disable DPI Scaling on Hi DPI Devices"
2) HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers and add a string value REG_SZ whose name is the full path to the application executable and whose value is HIGHDPIAWARE

Open IntelliJ. Everything will be very small. Now go into the settings of IntelliJ and set the fonts for the text editor and general to 26pt.

Enjoy lush looking text in your IDE that's a joy to work with.

Took me a long time to work all this out although the solution is ultimately a simple one. I really hope this post helps someone else in the future.

Happy Coding! :)

0

YOU ARE A LIFESAVER!

Thanks. Worked a treat.

Haven't checked if you need don't need the reg key, but this worked.

Nice one.

0

Please sign in to leave a comment.