Is the internal build option completely gone now?

Or did it just move somewhere I can't find it?

The external build option never worked well for me with IDEA 12 and appears to completely fail under 13.
It immediately used up all heap in both the IDE and compiler processes, goes through cleaning and parsing phases fine, - then doesn't appear to doing anything much with the CPU and just says "writing classes" for as long as I had patience to sit and wait for it.
It's probably something to do with my environment (crappy windows XP SP3 environment, running all manner of virus scanners and other enterprise cruft).  

But first things first: can I go back to the old way?

Permanently deleted user

Hi Shorn,

The "old way" is deprecatred and already differs from the new implementation in terms of "correctness". Sooner or later the old code will be removed completely, so we'd better understand what is going wrong with your system and fix it now. Could you please create an issue in youtrack and describe in details your project and how the build goes on?



I was wrong about the CPU thing, it's actually pegging a single core - which tells me the problem might be that it's running out of heap (my compiles are normally I/O bound - very slow disk, etc.)
Tried setting the compiler to use 1GB of heap, still just went straight to max size (1GB of working set/private bytes) and then pegged the CPU again.
1.5GB of heap wouldn't start (could not start javac, I mean) and  .5GB of heap dies with an OOM error.

Then I switched over to "Use Compiler: Eclipse" and it seems to work fine now.


We too have had problems with the high memory usage of IDEA's "external make". With the "internal make" option gone for IDEA 13, that becomes a more important problem.

I've filed issue (External make uses too much memory) for this.


The issue raised has been changed to status "incomplete" - what does "incomplete" mean?


It means there is a question to reporter, the answer to which is necessary to resolve the issue, but is not received.



Please sign in to leave a comment.