IDEA won't execute only one SQL statement - help?

Recently (within the last week), IDEA has started to execute every SQL statement in the console when I execute against MSSQL.  This is as opposed to the prior behavior where only the SQL statement under the cursor would execute.  Now when I put my cursor in the console editor, it highlights all lines.  It used to only highlight the statement containing the cursor.  This is regardless of the use of semicolons between statements.

I really want the old behavior back.  I can't seem to figure out how to execute only the highlighted statements or the statement under the cursor, and would really rather not clear out the console for every new query I want to execute.

Also, the console editor won't let me change the SQL dialect because of something it calls "batch mode" being enabled.  I looked for the batch mode option to toggle it off, thinking that this may be what the issue is with executing all statements, but the only reference to this control I can find is that it is "hidden in the console properties dialog".  Well, it's well-hidden because I can't find it at all.

Please help?

Please sign in to leave a comment.