19 comments

Wow - you mean you can actually open projects with it? I can't even get that far:

2013-07-26 11:01:51,631 [ 105525]  ERROR - ij.components.ComponentManager - com/intellij/execution/LocatableConfigurationType
java.lang.NoClassDefFoundError: com/intellij/execution/LocatableConfigurationType
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:465)
        at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:154)
        at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:150)
        at com.intellij.util.lang.UrlClassLoader._findClass(UrlClassLoader.java:126)
        at com.intellij.ide.plugins.cl.PluginClassLoader.b(PluginClassLoader.java:103)
        at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:64)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:249)
        at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.loadClass(ExtensionComponentAdapter.java:148)
        at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getComponentImplementation(ExtensionComponentAdapter.java:63)
        at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getComponentInstance(ExtensionComponentAdapter.java:70)
        at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getExtension(ExtensionComponentAdapter.java:111)
        at com.intellij.openapi.extensions.impl.ExtensionPointImpl.processAdapters(ExtensionPointImpl.java:241)
        at com.intellij.openapi.extensions.impl.ExtensionPointImpl.getExtensions(ExtensionPointImpl.java:185)
        at com.intellij.openapi.extensions.Extensions.getExtensions(Extensions.java:111)
        at com.intellij.openapi.extensions.Extensions.getExtensions(Extensions.java:98)
        at com.intellij.execution.impl.RunManagerImpl.a(RunManagerImpl.java:110)
        at com.intellij.execution.impl.RunManagerImpl.<init>(RunManagerImpl.java:85)
        at sun.reflect.GeneratedConstructorAccessor27.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.picocontainer.defaults.InstantiatingComponentAdapter.newInstance(InstantiatingComponentAdapter.java:193)
        at org.picocontainer.defaults.ConstructorInjectionComponentAdapter$1.run(ConstructorInjectionComponentAdapter.java:220)
        at org.picocontainer.defaults.ThreadLocalCyclicDependencyGuard.observe(ThreadLocalCyclicDependencyGuard.java:53)
        at org.picocontainer.defaults.ConstructorInjectionComponentAdapter.getComponentInstance(ConstructorInjectionComponentAdapter.java:248)

0

After wiping all settings I was able to get things to load and (sort of) run.  Lots not working in a Django project:

9:25:54 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:04 PM Throwable: Conflicting component name 'SshConsoleOptionsProvider': class com.jetbrains.plugins.remotesdk.console.SshConsoleOptionsProvider and class com.jetbrains.python.remote.console.SshConsoleOptionsProvider
9:26:08 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:21 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:24 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:30 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:32 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:36 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment
9:26:44 PM NoClassDefFoundError: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment: com/intellij/openapi/editor/markup/GutterIconRenderer$Alignment


Sent a bunch of bug reports.
0

Greg, please try disabling any 3rd party plugins

0

Please try disabling Scala plugin.


0

I don't have the Scala plugin or any third party plugins installed.  Deleted everything and reinstalled from scratch.

I'm on Ubuntru 13.04 as well, Oracle JDK 6 (also tried 7 with the same results.  FWIW.)

0

I had the same problem.
Disabling the ruby plugin did the trick

0

Pretty sure this is all Jetbrains:

Conflicting component name 'SshConsoleOptionsProvider': class com.jetbrains.plugins.remotesdk.console.SshConsoleOptionsProvider and class com.jetbrains.python.remote.console.SshConsoleOptionsProvider



0

I don't have the Ruby plugin installed.

0

Same here on OS-X 10.8.4 - when I open a project from the splash screen, nothing happens. No esoteric plugins except Scala and Play 2 installed.

Peter

0

Start_Failed.png
Yup, completely bjorked on MacOSX 10.8.4

Luckily have the last one lying around.

0

Yup same here. Totally broken - tried a lot of different things but each time got to splash screen, and then project load but then it failed to load or import any projects. First time  in many years for me to have an EAP build totally not work at all.


2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - IntelliJ IDEA (Cardea) IU-130.1365  Build #IU-130.1365
2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - JDK: 1.7.0_10
2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - Vendor: Oracle Corporation
2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - OS: Windows 7
2013-07-26 18:02:20,185 [   6521]  ERROR - ij.components.ComponentManager - Last Action:  
2013-07-26 18:02:20,190 [   6526]  ERROR - ij.components.ComponentManager - com/intellij/execution/LocatableConfigurationType
java.lang.NoClassDefFoundError: com/intellij/execution/LocatableConfigurationType


Is one example of the many exceptions being thrown...

0

erikjfreed wrote:

Yup same here. Totally broken - tried a lot of different things but each time got to splash screen, and then project load but then it failed to load or import any projects. First time  in many years for me to have an EAP build totally not work at all.

Yes, it was quite a shock :O

It is an EAP and, as you say, they've been pretty stable for years.

0

I'm new to IntelliJ and new to this community, so sorry if this "me too" is unwelcome. I'm on OS X 10.8.4, play 2.1.2 (using Java 1.6.0_51 and Scala 2.10.0) installed. The ideaIU-130.1365 build installs ok, but becomes unusable when restarting after adding Scala plugin. I get the same "Internal Exception" splash screen.

It seems previous v13 EAP builds are unavailable for download?

0

Same here. I removed my .IntelliJIdea13 directory and then it launched but I couldn't open project.  So I rolled back to the previous release: http://download.jetbrains.com/idea/ideaIU-130.1179.tar.gz

0

Remember[1] :

Be Careful
It is important to distinguish EAP from traditional pre-release software. Please note that the quality of EAP versions may at times be way below even usual beta standards.


meanwhile previous builds;
for windows - http://download.jetbrains.com/idea/ideaIU-130.1179.exe
for mac - http://download.jetbrains.com/idea/ideaIU-130.1179.dmg
for *ux - http://download.jetbrains.com/idea/ideaIU-130.1179.tar.gz

[1]http://confluence.jetbrains.com/display/IDEADEV/IDEA+13+EAP

0

Though I know it is an early access build, I'd really appreciate it if
Jetbrains quickly could fix this serious bug. Basically, you want us to test
your software in environments where you can't test. Hence, a little bit more
effort on your side to get us up and running again would help you. Otherwise
users will take your EAP statement literally - don't try any version X
before X.y.4.

Tom

0

Well that won't help my scala project any now will it ;-)

Are there Cardea specific builds of the Play/Scala plugin yet?

0

I note the OSS Community Git repository no longer even compiles - and hasn't for the last week ;(  At least according to my Jenkins job.  Unless the build process has changed...

0

Please sign in to leave a comment.