Problems importing a multi-platform Gradle project.

When I try to import one of my projects from an existing git clone, using "Import project from external model" -> Gradle, I get this message when trying to finish the import:

https://lh4.googleusercontent.com/-DFs0n745cyM/UccotKLG41I/AAAAAAAAUOY/D2uVkfFwYn0/w739-h161-no/idea13-wtf.png

This Gradle project contains both Java desktop modules and Android modules. I've tried both using the projects gradle wrapper and my local copy, as well as diddling the auto import checkbox without luck. Also happens if try to have IDEA check it out  from github. Ditto if I comment out the include's for the android related modules from my settings.gradle, still not importing.

What am I doing wrong here? It's not quite like I can do 'Help | Show Log' when it sends me to a web browser if I hit help ;).

Now if I go make a sample Hello World project and try to import the project, I get further along and poked at not being able to find the Andorid SDK. If I run idea.exe from a cmd window with ANDROID_HOME set, it works up to telling me I haven't updated this machines Android SDK in way too long. After doing that, it gets as far as telling me it's unable to find one of my modules (pngdecoder) and lists some registered modules (scripting, android, pc, core), which is a subset of what is included in my settings.gradle file.

There is no log file in ${install prefix}\system\log\ when I do this but there is a fair bit of output to my cmd.exe window.

Refs:

2 comments

Hi Terry,

Reproduced the problem locally, thanks. Looks like android-specific 'import from gradle' processors are not fault-tolerant.

Created corresponding ticket - IDEA-109458.

Denis

0

Please sign in to leave a comment.