SVN: Have to commit twice to get all files committed

Lately, I have to commit twice to get all my changed files committed to the repository. The first commit only commits the top-level directory. I have to do an additional commit to commit the remaining files and directories. This problem occurs on about 50% of my commits from IDEA. The problem does not happen at all when I commit using TortoiseSVN. I'm not exactly sure, but I believe this started happening around 128.101.

My current configuration:

  • IU 129.111.
  • Replicated subversion repository accessed over https.
  • Subversion server 1.6.5.
  • Subversion client (TortoiseSVN) 1.7.8.
  • IDEA is configured to use command-line client for Subversion 1.7 acceleration (Is this actually used for commits? Or, just for status?)


One thing I have noticed is that TortoiseSVN shows that the top-level directory is not in any change list while IDEA says it is in my active change list. (See attached screen shots. "sms" is the root of my working copy and repository.) Could this be relevant?

Let me know if I can provide additional information.

Thanks.



Attachment(s):
tortoisesvn.PNG
idea.PNG
3 comments

Hello Chris,
Could you please write us, at least roughly, in which cases you notice it.
It can be relevant, for example, in case you revert changes from changes=>repository(when patch is created), in case of merge(new changelist is created), also not all changes will be commited if focus is not on project, but on any file or directory.

0

Hello Daria.

The problem happens when I merge or reintegrate a branch. I believe these are the only times any properties change on the top-level directory in my environment.

Also, the problem only happens when IDEA is configured to use the command-line client for Subversion 1.7 acceleration. If this option is not selected, the entire changelist is committed as expected.

I always commit at the changelist level. Never an individual file or subdirectory.

Thanks.

0

Chris,
Thanks for information. We will try to reproduce  and fix it.

0

Please sign in to leave a comment.