Can't customize toolbar

I want to put a "Toggle Bookmark" on the toolbar so I right-clicked beside the toolbar and selected "Customize Menus and Toolbars". I got a rather confusing tree of settings, but eventually found "Revert Selected Changes" and clicked "Add After...".  After navigating another confusing tree, I found "Toggle Bookmark" so I selected that and "OK". Now I have the "Toggle Bookmark" appearing under the "Revert Selected Changes" in the first confusing tree, but I don't see it on the toolbar, even if when I restart PhpStorm.

I'm running PhpStorm 2016.1.2 on 64-bit Ubuntu.

5 comments

Hi there,

Please provide screenshots:

1) how your toolbar looks like (when actually using IDE)

2) how you have customized it (I need to clearly see what menu/toolbar you are editing)

Right now it's possible that you are editing wrong one.

0

So I was expecting to see that CGA tile beside the hairpin icon on the toolbar.



0

As suspected...

There are 2 toolbars: Main and "Mini".

You 1st screenshot shows Main Toolbar in use .. but on 2nd screenshot you are editing "Mini" one (Navigation Bar Toolbar).

Basically ... when you have "Menu | View | Toolbar" active you will see Main Toolbar (like you have right now). When you disable it .. Main Toolbar will be hidden (so you will have a bit more vertical space for the code).. and you will see "Mini" toolbar on the right side of Navigation Bar.

So .. either edit right toolbar ("Main Toolbar") ... or disable it via "View | Toolbar" and see the changes that you have done so far (Navigation Bar Toolbar)

---

P.S. Keyboard shortcuts are much faster :)

P.P.S. You can edit Editor Gutter Menu .. or Editor Context Menu there as well.

3

EDIT: I get it!! Navigation bar toolbar

Hi

 

Are there any way to customize these "Mini" toolbar??

 

Regards

 

 

0

Yeah, I found it!

Settings -> Appearance & Behavior -> Menus and Toolbars -> Navigation Bar Toolbar

 

I know this question is old, but maybe someone is having the same issue and comes here by google (like I did).

0

Please sign in to leave a comment.