JDWP error - address already in use

I've tried a few builds of Leda now, and I always run into this wall, and have to go back to 11.1:

When I run a Maven deploy from IDEA 122.746:

"C:\Program Files\Java\jdk1.7.0\bin\java" -Xms512m -Xmx1024m -XX:MaxPermSize=256m -Xdebug -Xrunjdwp:transport=dt_socket,address=4000,server=y,suspend=n -Dclassworlds.conf=C:\apps\apache-maven\bin\m2.conf -Dmaven.home=C:\apps\apache-maven -Didea.launcher.port=7533 "-Didea.launcher.bin.path=C:\Program Files (x86)\JetBrains\IntelliJ IDEA 122.746\bin" -Dfile.encoding=UTF-8 -classpath "C:\apps\apache-maven\boot\plexus-classworlds-2.4.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 122.746\lib\idea_rt.jar" com.intellij.rt.execution.application.AppMain org.codehaus.classworlds.Launcher --offline --no-plugin-registry --fail-fast --strict-checksums --update-snapshots -DskipTests=true install
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
ERROR: transport error 202: bind failed: Address already in use
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:741]

Process finished with exit code 1

(FAIL)


When I do the same Maven deploy from the same project in IDEA 11.1:



"C:\Program Files\Java\jdk1.7.0\bin\java" -Xms512m -Xmx1024m -XX:MaxPermSize=256m -Xdebug -Xrunjdwp:transport=dt_socket,address=4000,server=y,suspend=n -Dclassworlds.conf=C:\apps\apache-maven\bin\m2.conf -Dmaven.home=C:\apps\apache-maven -Didea.launcher.port=7532 "-Didea.launcher.bin.path=C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.1\bin" -Dfile.encoding=UTF-8 -classpath "C:\apps\apache-maven\boot\plexus-classworlds-2.4.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.1\lib\idea_rt.jar" com.intellij.rt.execution.application.AppMain org.codehaus.classworlds.Launcher --offline --no-plugin-registry --fail-fast --strict-checksums --update-snapshots -DskipTests=true -f C:\Source\platform-standard-trunk\service\pom.xml install
Listening for transport dt_socket at address: 4000
[WARNING] Command line option -npr is deprecated and will be removed in future Maven versions.
[INFO] Scanning for projects...

...
(SUCCESS)


Is IDEA 12 latching on to some port that it did not previously use? I also notice that the pom.xml is not referenced explicitely in IDEA 12. Is this possibly the problem?

Any ideas are welcome.

thanks

Please sign in to leave a comment.