Where is the "do not show this dialog" option for auto-format code in 14.1.4?

In Windows, by default, Code -> Reformat Code is `CTRL+ALT+L` and "Show Reformat File Dialog" is `CTRL+ALT+SHIFT+L`.

The latter window has no "show this dialog in the future" checkbox.  

I believe it used to live under Settings -> Editor -> General -> Formatting, but in 14.1.4, the only options there are "Show notification after reformat code action" and "Show notification after organize imports action".

How it used to be, apparently:

http://stackoverflow.com/questions/27747355/intellij-idea-how-to-revoke-reformat-code-optimize-imports-dialog
http://stackoverflow.com/questions/9344667/intellij-idea-code-reformat-options

How can I re-enable the "show this dialog" option?  

How can I change the default Reformat Code... settings (scope, in particular)?  

8 comments
Comment actions Permalink

You have 2 shorcuts now, one with the dialog and another without the dialog. Use the one you need.

https://youtrack.jetbrains.com/issue/IDEA-141352#comment=27-1013134

0
Comment actions Permalink

OK; what I want is to change the default scope setting "Whole File" to "Only VCS Changed Lines", so that only changed lines in files that are checked in are automatically formatted.

Where can I change the defaults?

0
Comment actions Permalink

You can change it in CTRL+ALT+SHIFT+L dialog.

0
Comment actions Permalink

Thank you....

But that brings up a dialog for that specific file; for example, "Only VCS changed text" is greyed out if the file hasn't been changed.  

I have just verified that changing it on a changed file does not change the default settings for subsequent uses.

0
Comment actions Permalink

https://devnet.jetbrains.com/message/5556644#5556644 states that it should work. Are you sure that invoking reformat without a dialog doesn't preserve the scope that was set in the dialog before?

0
Comment actions Permalink

Hi, Jordan!
Unfortunately it is a bug. It is already fixed in our Intellij IDEA 15 EAP, and will be backported into 14.1 soon.

0
Comment actions Permalink

Roger.

Is there any workaround available?

0
Comment actions Permalink

If you set up "only VCS changed text" on file which has changes, and after that you will reformat code with Ctrl-Alt-L (without dialog) everything should work fine, because Ctrl-Alt-L uses last saved state from Ctrl-Alt-Shift-L

0

Please sign in to leave a comment.