"Processing Maven resources" needlessly slows me down

Hi

Whenever I run a test or a Java application in my IDE, I am always forced to wait 20 or 30 seconds for "Processing Maven resources...", even when nothing has changed in my project.  In times of intense dev/test activity this is a real drag on my time!
Does anyone know what is going on and how I can stop it?  I have tried toggling Maven on-/off-line (under Maven Projects), but it seems to make no difference.

Thanks for any pointers  :-)

- Chris

PS I am running IDEA 10 (see graphic) on Mac OS X 10.6.6
about-idea.png

7 comments

When you import a maven process, you can choose what maven phase will get run before build, you can probably set it to nothing.  The default is process-resources, which is causing your slowdown.

I really wish maven had a flag to not copy the files if they are not newer...

(well, there is http://maven.apache.org/plugins/maven-resources-plugin/resources-mojo.html#overwrite, but it doesn't seem to work for me)

0

The point probably is this is a performance regression in 102.149 - working on a pure junit test is a royal pain now. IDEA didn't need this 30 secs delays before.

0

Thanks Gustavo - can you steer me towards the settings you mean?  I have had a look, but nothing quite seems to match your description..  presumably it is connected to the Make or Build settings?

0

Could you please create a YouTrack issue and attach a CPU snapshot?

Thanks,
Anton Makeev

0

I'm still seeing this in IU-117.912 and I also am not sure where I can rachet this down for maven?
//rob

0

I managed to solve this once I figured out what it was doing (which wasn't obvious...)

I had built a structure of directories in the 'resources' folder in which I had placed some very large files.  What was happening was that these files would be copied into the 'target' directory every time I built the project.  The solution?  Put the large files somewhere else!

Hope this helps  :-)

- Chris

0

Please sign in to leave a comment.